Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,753
Community Members
 
Community Events
176
Community Groups

Why clover throws error "No Clover instrumentation done on source files" while instrumentation?

Edited

Unable to instrument the source code on my java project with maven 3.6.3 and openclover-4.4.1

Hi Team

I am not sure why I continuously get the below error while trying to instrument the java source code.

 --- clover-maven-plugin:4.4.1:instrumentInternal (clover.inst) @ project1 ---

[INFO] No Clover instrumentation done on source files in: [/Users/paritosh/ABC/project1/src/main/java] as no matching sources files found (JAVA_LANGUAGE)

[INFO] No Clover instrumentation done on source files in: [/Users/paritosh/ABC/project1/src/test/java] as no matching sources files found (JAVA_LANGUAGE)

[INFO

I tried providing the exact path of the java file as well in the configuration but every time it threw the same error message. Even I tried the goal of maven clover:setup but it threw the same message.

Due to this, no clover database is getting generated hence there are no reports. 

  No Clover database found, skipping report generation

My project uses java 11. I read somewhere that there is no support for java 11 as of now but is there any upcoming plan for this.

Also, is the error which is coming up due to this java version? Is there any work around for now.

Code snippet from pom.xml:

<groupId>org.openclover</groupId>
                    <artifactId>clover-maven-plugin</artifactId>
                    <configuration>
                        <targetPercentage>10%</targetPercentage>                    <cloverDatabase>${project.build.directory}/clover/clover.db</cloverDatabase>
                       <debug>true</debug>
                        <includes>                                    <include>${project.source.directory}/</include>
                        </includes>
                    </configuration>
                    <executions>
                        <execution>
                            <id>clover.inst</id>
                            <phase>validate</phase>
                            <goals>
                                 <goal>instrument-test</goal>
                                <!-- <goal>setup</goal> -->
                            </goals>
                        </execution>

 

It would be really great if I can get some ideas on this. Please let me know if any other information is required.


0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events