Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

can't connect crowd to ldap


in crowd, i pressed 'add directory'

i defined the connector, tested it and it worked.

i then defined the configuration, set the timeout to be very long and clicked 'test'

nothing happens for a while and then a blank page loads in the browser with the url:


the logs only have one line in them:

2012-08-08 18:20:42,995 http-8095-5 WARN com.opensymphony.xwork.DefaultActionInvocation No result defined for action and result input

i did tcpdump on port 389, and there is definetly activity there.

3 answers

I'm having exactly the same issue. I've enabled debug logging and I see a timeout:

2012-12-10 20:30:21,075 Timer-0 DEBUG [mchange.v2.resourcepool.BasicResourcePool] EXPIRED idle resource: com.mchange.v2.c3p0.impl.NewPooledConnection@19e8dd7a ---> idle_time: 35045; max_idle_time: 30000 [com.mchange.v2.resourcepool.BasicResourcePool@2bf525ec
2012-12-10 20:30:21,076 com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#0 DEBUG [v2.c3p0.impl.C3P0PooledConnectionPool] Preparing to destroy PooledConnection: com.mchange.v2.c3p0.impl.NewPooledConnection@19e8dd7a
2012-12-10 20:30:21,078 com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#0 DEBUG [v2.c3p0.impl.NewPooledConnection] com.mchange.v2.c3p0.impl.NewPooledConnection@19e8dd7a closed by a client.
	at com.mchange.v2.c3p0.impl.NewPooledConnection.close(
2012-12-10 20:30:21,080 com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#0 DEBUG [mchange.v2.resourcepool.BasicResourcePool] Successfully destroyed resource: com.mchange.v2.c3p0.impl.NewPooledConnection@19e8dd7a
2012-12-10 20:30:33,880 http-8095-1 DEBUG [atlassian.xwork.interceptors.TransactionalInvocation] Committing transaction for action /console/secure/directory/testPrincipalSearch.action (CreateConnector.testPrincipalSearch())
2012-12-10 20:30:33,880 http-8095-1 DEBUG [atlassian.xwork.interceptors.TransactionalInvocation] Creating transaction for action result: /console/secure/directory/testPrincipalSearch.action (CreateConnector.testPrincipalSearch())
2012-12-10 20:30:33,880 http-8095-1 WARN [com.opensymphony.xwork.DefaultActionInvocation] No result defined for action and result input

what solved the problem for me was downgrading from crowd 2.5 to 2.4.1

Hi Gregory,

Good to know that the problem is solved now. If you experience any other problem please feel free to raise a support ticket at our and we will be glad to help you.



Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

195 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you