Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,051
Community Members
 
Community Events
176
Community Groups

Trying to run Crowd as a service, results in Error 404?

I am trying to get Crowd to run as a non-privileged user on Linux (user: atlcrowd) but it doesn't appear to be working. I've been able to enable SSL on my Crowd environment by adding a Connector 8443 to the server.xml section under Apache Tomcat. The atlcrowd user has full owner and group permissions (owner and group) of /opt/atlassian/crowd (where the binaries are installed) and /var/atlassian/crowd (where the Crowd home directory is located). But if I attempt to run /opt/atlassian/crowd/start_crowd.sh as the atlcrowd user, I can get the initial screen at https://crowd.<mydomain.com> but if I try to get to the console screen (/crowd/console) I get an Error 404 message.

However, if I stop and start the Crowd service as root, everything works fine. Is there another directory that the atlcrowd user needs to have permissions on in order to fully function? (Error attached)
OS: CentOS 7.4
Crowd Version: 3.1.2

2 answers

1 accepted

0 votes
Answer accepted
edwin Rising Star Feb 10, 2018

Hi,

Make sure all the files under those directories are owned by atlcrowd

chown -R atlcrowd:atlcrowd <home/app dirs>

There is also a Crowd service script you can use

https://confluence.atlassian.com/crowd/setting-crowd-to-run-automatically-and-use-an-unprivileged-system-user-on-unix-211649189.html?_ga=2.218837721.1391339591.1517455096-1812859764.1517455096

Marcin Kempa Atlassian Team Feb 14, 2018

Indeed it turned out to be a permission issue.

For the record, Crowd needs to have permissions to application (Crowd install), home and share home directories.

0 votes
Marcin Kempa Atlassian Team Feb 10, 2018

Hi @OneTech IT,

 

I assume that you've seen Crowd's documentation about running Crowd as unprivileged system user.

I believe that directories you've mentioned are all that Crowd needs to have access to, but in order to resolve your problem we will need to check the log files both from Crowd and Tomcat. We can create a support issue for you if you do not want to share those logs publicly here.

 

 

Best regards,

Marcin Kempa

I submitted a ticket last night but have received no notifications that it has been received by a support technician,.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events