Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,045
Community Members
 
Community Events
176
Community Groups

SSO with Crowd and cookie hassle

Hi community,

I am running Confluence, Jira Core, Service Desk and Crowd under the same local IP address and PostgresQL, different ports though. Crowd setup works, bidirectional application linking as well, everything fine.

I find myself with the situation that I have to constantly re-enter user id and password and get kicked out constantly of the account. It seems, this entire setup causes havoc and the cookies do not differentiate ports, which sucks big time.

Questions:
1.) Any suggestions how tho get this working, besides using several independent browsers?
2.) Would a workaround with subinterfaces work, binding the applications to different IP-Addresses? if so, where do I change the IP address  Attlassian applications bind to at startup?

Thanks a lot,
Gernot

1 answer

1 accepted

0 votes
Answer accepted

Hello @GSC

1/ Please take a look at this KB for a list of resolution strategies for this problem.

2/ If the IP addresses are resolved to the same server name, that won't be of any help. The closest approach to this is to have different DNS entries for your IP, for instance  confluence.yourdomain.com, jirasd.yourdomain.com. In such a case Crowd SSO obviously has to be configured for yourdomain.com.

Hi, I am not using DNS.

Well, as Crowd SSO is domain based, I strongly suggest that you do.

If for some reason you can't bind to a DNS server, you can add entries to the hosts file of your computer (C:\Windows\System32\Drivers\etc\hosts on Windows, /etc/hosts on macOs and Linux). For instance:

127.0.0.1 localhost jira.yourdomain.com jirasd.yourdomain.com confluence.yourdomain.com

Then add yourdomain.com as the Crowd SSO domain in the general settings of Crowd's administration console.

Went with the context path modification option for the time being, works fine now.

Thanks for your assistance!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events