Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SSO domain invalid after moving to production

Good day,

We decided to implment Atlasian crowd in our intrastructure after some testing. So we created a new server and added it to our main database server postgresql as backend.

 

I exported the configuration "with out domain" and imported it back into crowd production, the inport goes well and all the users are able to login. When that worked we implemented the SSO again and that is where we are stuck...

 

We did evyerhing as in our test instance, but the SSO domain as .domain.tld and enabled the SSO cookie option.

After saving it seems to work,, but when I login as administrator to the CROWD console I see the logs spamming with the following error:

ERROR [crowd.integration.springsecurity.AbstractCrowdSSOAuthenticationProcessingFilter] Unable to set Crowd SSO tok$
java.lang.IllegalArgumentException: An invalid domain [.domain.tdl] was specified for this cookie

We use the following setup

Backend: Postgresql 9.4 on a UBUNTU 16 LTS

Crowd server: Ubuntu 18.01 LTS and OpenJDK-8-JRE-HEADLESS

Haproxy latest as our main proxy for SSL offloading

 

Can somebody point me in the right direction?

 

1 answer

1 accepted

1 vote
Answer accepted
Bruno Vincent Community Leader May 01, 2018

Hi @schuurdeur

You just need to remove the leading "." character from the SSO domain value in the General Options of your Crowd server. For instance domain.tld instead of .domain.tld

That worked, thank you!

But then the Documentation is "wrong".

Example 1: If you wish to have single sign-on (SSO) support for *.mydomain.com, you will need to configure the SSO domain in Crowd as .mydomain.com — including the full stop ('.') at the beginning. All your Crowd-connected applications must be in the same domain. For example:

https://confluence.atlassian.com/crowd/overview-of-sso-179445277.html

Bruno Vincent Community Leader May 02, 2018

You're welcome! Yes, you're right, the documentation definitely needs to be updated.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

267 views 8 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you