Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,417
Community Members
 
Community Events
177
Community Groups

How to set up crowd on another url?

I have a problem with authentication from another pc. I've unpack crowd server,setting up mysql bd like in Manual , configure server.xml in apache-tomcat directory to set up proxyName and proxyPort for connector block(i make redirect from Nginx like JIRA or Stash).

When i start crowd,i can access for start page,i choose install crowd and after all steps i couldn't login

Connection to authentication server failed. Please review the logs for more information.

Pastebin log


why he can't login?


i updated crowd.properties changing application password from data folder to bin/client/conf folder and bin/crowd-webapp/WEB-INF/classes folder

1 answer

0 votes

It's because you've got the wrong connection settings.  The last error in the log is a giveaway:

  1. 2014-09-21 16:07:14,832 http-bio-8095-exec-19 ERROR [crowd.console.action.Login] Failed to connect to the authentication server, please check your crowd.properties
  2. org.springframework.security.authentication.AuthenticationServiceException: The application.name or application.password in the crowd.properties file does not match the password in Crowd.

where should a change it? i update password in 2 directories bin/client/conf folder and bin/crowd-webapp/WEB-INF/classes folder and get this error again((

Check the crowd.properties under CROWD_HOME (data directory) and make sure the application password in the crowd.properties file is correct.

Another thing to check would be the URL in the same file. It should be localhost or the ip address of the machine.

If you want to reset the password, try this:https://confluence.atlassian.com/display/CROWDKB/Getting+InvalidAuthenticationException+in+the+Log+File+When+Logging+into+Crowd

what does it mean correct?i have password in crowd.properties but how i know that it is correct?

It means you've given it the wrong password. It does not match with what you have put in Crowd to allow it access. You need to check that what you've set up in Crowd matches what you've set in the file. Generally, you won't be able to read a password though, you'll need to change it to be 100% sure what is in there. I tend to use copy and paste to do this, so that I know I'm using the same source password every time.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events