Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,410
Community Members
 
Community Events
177
Community Groups

How to change the Crowd URL and domain and keep SSO working?

I am trying to change the URL (and IP) of my local, standalone Crowd instance, but it will not accept my new domain.

I changed the URLs in crowd.properties; changed the allowed remote addresses of registered applications; and changed the Crowd URL for the user directories in the remote applications (in this case, Confluence).

The changes did not go smoothly (e.g. I had to tweak the domain attribute directly in the database), but eventually, I got everything working except SSO.

Now, I keep getting this error (from the crowd logs):

Invalid SSO Domain value: '.newdomainname.com' found in settings. Domain currently in use is: 'oldhostanme.olddomainname.com'.

I have searched the entire installation and home folders for the "oldhostname" and I cannot find it. I have also searched the cwd_property table in the database.

Any suggestions?

Addendum:

I'm running Apache but not using Virtual Hosts.

1 answer

SSO is working now, but I still get the error message about the SSO domain value.

The problem with the SSO was that the Authenticator class in Confluence was not the SSO authenticator class (missed this during an upgrade).

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events