Error when trying to install the Crowd-Apache plugin

I am trying to install the Crowd Apache plugin on Ubuntu Server 12.04 but I get the following error while executing ./configure:

checking for apr_pool_pre_cleanup_register in -lapr-1... no
configure: error: apr_pool_pre_cleanup_register was not found in libapr-1

Any ideas on how to solve it?

Another question I have is if it is possible to copy the plugin from one server (where it works) to another one without actually compiling and installing it. Is there maybe a list of files that can be copied like this or is it impossible?

Thank you!

3 answers

1 accepted

This widget could not be displayed.
The only thing left to do was to install the entire system from scratch and fix the problems with the lib dependencies. Somehow, someone installed the libxml2 lib from 12.10 and downgrading was very risky. Using backups of the tools, it all worked well and took half a day. Now we have a working, clean system.
This widget could not be displayed.

UPDATE: i tried manually copying the following files from the server where the plugin works:

/usr/lib/apache2/modules/mod_authz_svn_crowd.so

/usr/lib/apache2/modules/mod_authnz_crowd.so

/etc/apache2/mods-available/authz_svn_crowd.load

/etc/apache2/mods-available/authnz_crowd.load

/etc/apache2/mods-available/dav_svn.conf

/etc/subversion/dav_svn.authz

I then loaded the 2 new modules (mod_authnz_crowd and mod_authz_svn_crowd).

Upon service apache2 restart I get the following error:

apache2: Syntax error on line 239 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/authz_svn_crowd.load: Cannot load /usr/lib/apache2/modules/mod_authz_svn_crowd.so into server: /usr/lib/apache2/modules/mod_authz_svn_crowd.so: undefined symbol: dav_svn_get_repos_path

No idea what I am missing...

This widget could not be displayed.

Are you using the supported versions of Apache (2.2) and SVN (1.6) ? The errors you're seeing are about what I would expect if you were trying to use different versions than what we have tested against.

I am using Apache 2.2.22 and SVN 1.7.9. I am sure the SVN version is not the issue since I have the same setup running on another server.

It might be that there are wrong versions of libs installed on this server. I fixed the first issue (did some forced downgrading of some components) but now the problem is with the libxml2:

checking for xmlFree in -lxml2... no
configure: error: libxml2 was not found

root@deathstar:/srv/atlassian/kits/mod_authnz_crowd-2.2.2# apt-get install libxml2
Reading package lists... Done
Building dependency tree
Reading state information... Done
libxml2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I probably need to somehow fix this package too...

You may want to try installing the libxml2-dev package too.

I tried that (and probably found the issue):

libxml2-dev : Depends: libxml2 (= 2.7.8.dfsg-5.1ubuntu4.9) but 2.8.0+dfsg1-5ubuntu2.2 is installed.

I would need to downgrade libxml2. Some very weird dependencies here :(

Unfortunately maintaining support for older versions of RHEL means we have to build against old versions of libs, but I agree - that's some strangeness there!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Feb 27, 2018 in Crowd

The Crowd team is looking for feedback on Server & Data Center customers' identity strategies!

Do you own more than one Server or Data Center product? Do you have challenges provisioning users across your Atlassian products? Are you spending a lot of time integrating each Atlassian product wit...

1,449 views 6 14
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you