Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,619
Community Members
 
Community Events
176
Community Groups

Error in log: credentials in request: true , allowed via CORS: false

Hello

Various actions in the Crowd web interface generates this and similar errors:

2019-05-22 13:15:46,085 http-nio-8095-exec-17 WARN [common.security.jersey.XsrfResourceFilter] Additional XSRF checks failed for request: http://deutz.domain.ch:8095/crowd/rest/admin/1.0/mail/configuration , origin: https://jira.domain.ch , referrer: https://jira.domain.ch/crowd/console/secure/admin/mailserver.action , credentials in request: true , allowed via CORS: false

It happens when clicking on password reset, sending test email, create support.zip.

Base URL of crowd is https://jira.domain.ch/crowd and the hostname is deutz.domain.ch.  

 

Crowd is running in following environment:

  • Application serverApache Tomcat/8.5.40
  • Crowd version 3.4.4 Build number1069 Build date2019-05-02
  • Java version 1.8.0_152
  • PostgreSQL 9.6
  • OS: Debian 4.9
  • Does anyone know how to fix this problem.

Thank you and best regards

Sonja

 

1 answer

0 votes
sara Rising Star May 22, 2019

This is due to cross origin headers.This can be fixed by enabling cors in web.xml in tomcat.

Hi Sarath

Thank you for the hint. I tried it with this cors Filter incrowd/install/apache-tomcat/conf/web.xml  but didn't work i have still the same error:

<filter-class>org.apache.catalina.filters.CorsFilter</filter-class>

<init-param>

<param-name>cors.allowed.origins</param-name>

<param-value>/*</param-value>

</init-param>

<init-param>

<param-name>cors.allowed.methods</param-name>

<param-value>GET,POST,HEAD,OPTIONS,PUT</param-value>

</init-param>

<init-param>

<param-name>cors.exposed.headers</param-name>

<param-value>Access-Control-Allow-Origin,Access-Control-Allow-Credentials</param-value>

</init-param>

<init-param>

<param-name>cors.support.credentials</param-name>

<param-value>true</param-value>

</init-param>

<init-param>

<param-name>cors.preflight.maxage</param-name>

<param-value>1800</param-value>

</init-param>

</filter>

<filter-mapping>

<filter-name>CorsFilter</filter-name>

<url-pattern>/*</url-pattern>

</filter-mapping>

Like 曹桂源 likes this
sara Rising Star May 22, 2019

This can also be configured in proxy by allow origin tag.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events