Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,407
Community Members
 
Community Events
176
Community Groups

CrowdID inaccessible

Hello,

I'm currently evaluating using Atlassian products for my projects. I installed Crowd today and got everything, but CrowdID to work. Following the guide here (https://confluence.atlassian.com/display/CROWD/Removing+the+'crowd'+Context+from+the+Application+URL) to remove the context path from my installation. I doubt this is relevant, but I also set up a reverse proxy using nginx for more convenient access. I'm now wondering how to access the CrowdID web interface. I guess I would either have to remove the context path and rewrite the URLs using nginx or set up another connector in Tomcat. Is there a way around this? In case setting up another connector in Tomcat is in option, what exactly would I have to do?

Thanks in advance,

Tobias

1 answer

1 accepted

2 votes
Answer accepted

Hi Tobias,

Can you access it from ?

http://localhost:8095/openidserver/

Hey, thanks for your answer. Unfortunately no. Accessing the page from localhost still returns the Tomcat 404 page.

Hi Tobias,

Are you accessing regularly from localhost or a machinename or proxy address? What is the URL you're currently using to access crowd?

Ultimately, you've changed the way crowd is accessed by removing the context, but you should still be able to set up another context resource that allows you to access the other areas of crowd.

If you add another 'context' resource in the crowd's server.xml pointing to the appropriate docbase, the /openidserver/ should resolve properly. You'll need to ensure that the nginx proxy is proxying properly to point those requests to the appropriate connector.

Hey, I'm currently running Crowd (and the other products aswell) on a dedicated server. Hence I'm accessing them through crowd.example.com, stash.example.com, ... This is why I preferred to have a reverse proxy, those port numbers look ugly ;) I will try to setup another connector later today. Thank you for your reply.

I totally understand that - entering ports is horrible for users. I pose this question to you though, how many users are actually logging into crowd? Should be very few (only your crowd admins). Crowd isn't an end user application :)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events