Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crowd behind IIS reverse proxy - no SSO

Hi,

I am rather technical novice with a web server and I am trying to setup JIRA, Confluence and Crowd with IIS reverse proxy within a single server. I followed the installation documents and successfully enabled all of these services with sub-domains, with some help with the method I found from a user comment within the documentation.( http://willhughes.me/20100112/jira-fisheye-and-iis7-using-application-request-routing/ )

The last problem is that SSO doesn't work within the three Atlassian products, while the Google Apps SSO worked flawlessly.

It is a bit odd that with the com.atlassian.crowd logging set to DEBUG or ALL, I am not getting any outputs when I open up the main page of JIRA or Confluence. (or could this be normal?)

Any help will be appreciated. Thanks!

3 answers

0 votes

Hi there!

I'm not very keen at reverse proxies configuration, however this could be causing some problem to the SSO cookie. Can you confirm the SSO worked before setting the reverse proxy?

If yes, then some rule in the proxy could be messing with the SSO. What you can try to do to troubleshoot this is to enable the debug logging into Crowd instead.

  1. In Crowd, go to 'Administration' -> 'Logging & Profiling'. Change the com.atlassian.crowd package to DEBUG.
  2. Replicate the SSO problem you are having.
  3. The new info should be inside the Crowd logs located at {CROWD HOME}/logs/atlassian-crowd.log}. If you need some additional help to debug the file, please raise a support ticket to us!

I hope this helps!

Rodrigo

Hi,

I'd also suggest that you take a look that the key points for enabling Crowd SSO in this other question.

Cheers

Exactly the same problem here, no SSO for Crowd, Confluence and JIRA behind IIS8 with ARR3 as reverse proxy.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

181 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you