Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I am currently working on SSL to do HTTPS for my applications. 

Only problem I have left is Crowd SSL.. 


I am following to do SSL however, it is not working. 

Main problem is.. I am trying to use same port for https.. Default port for http crowd is 8095 and I want to use 8095 for https.. 


On Step 1 of the link above, I couldn't find 

<Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
           maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
           clientAuth="false" sslProtocol="TLS"
           keystoreFile="${user.home}/.keystore" keystorePass="changeit"
           keyAlias="tomcat" keyPass="changeit"/> 
in my config file.. but there was original config 
<Connector acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" port="8095" redirectPort="8443" useBodyEncodingForURI="true" URIEncoding="UTF-8"/>
So I deleted that original connector statement and add the new connector statement on the link (1st connector statement) in that new statement I modified according to my key pass and set port to port="8095" instead of port="8443" 
On step 2 I did the steps in JIRA SSL which should be the same... (Also tried crowd link step 2) 
On step 3 
I modified all 3 config files.. My modification was just changing the http to https since I want to use the same port which is 8095.. so all I did was to change http to https in all 3 files.. 
After all this steps, when I run ./ it does not start the crowd.. 

netstat -plten |grep java returns only port 8020 which is the server port instead of 8095 with 8020.. 


tried accessing to http and https.. both of them does not work.. 

When I take out the new connector statement in step1, and put original one, at least it lets me go into http but not https (of course) 


Followed step1 exactly like the link... except my certificate config.. 

JIRA, Confluence, Stash is working fine with SSL except Crowd.. 


Can someone help me on this part? 

1 answer

1 accepted

2 votes
Answer accepted
rrudnicki Atlassian Team May 28, 2015

Hi Young, 

We received your support request. I'll be working through the ticket, and soon as we solve the issue I'll be posting the answer here for future references. 



Renato Rudnicki

I'm having the same issue. Was this ever resolved?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

328 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you