We have customer requirement for username format shall be like: 123/45678#001 Important part of this format is '#001'.
If we add groups to these users, no problems at all. If we remove one or more groups from these users we get the following error on web frontend: Cannot remove user "123/45678#001" from group(s) "Benutzerverwaltung".
See attached log file for further details. (atlassian-crowd.log)
Same error occurs when we are using REST-API for batch processing:
/crowd/rest/usermanagement/latest/group/user/direct?groupname=Benutzerverwaltung&username=123/45678#001
Before any questions come accros the '/' and '#' in URL: Yes, we do a HTML encode before ('/'=%2F and '#'=%23).
Interesting behavior is: The group is removed from the user account but the result is an error.
We are using OpenLDAP connector to store users and groups.