Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,315
Community Members
 
Community Events
165
Community Groups

Crowd Home path as an Environment Variable on Windows 64-bit

Can anyone tell me how to set the Crowd Home path as an Enviornment Variable on Windows 64-bit? It is the actual var name that Crowd expects that is unknown. There doesn't seem to be docs to setup an Environment Variable for Windows, although a comment in the actual crowd-init.properties suggests it can be done as an alternative.

2 answers

1 accepted

0 votes
Answer accepted

The variable name is the same as on *nix systems, and the same as the variable in the tmp file: crowd.home

On my linux system, I was able to set this variable in the tomcat's bin/setenv.sh and have Crowd recognise it.

If you're running Tomcat as a service on Windows, you might find this StackOverflow question and answer useful.

By the way, you can also specify the crowd.home property as a servlet context parameter.

Finally, if you add the line
log4j.logger.com.atlassian.config=DEBUG
to the end of crowd-webapp/WEB-INF/classes/log4j.properties then you'll get some debug information in the log as Crowd tries to read the property from each location.

Thanks Caspar. I apologize for the time it has taken for me to revisit and test this out. I did get this working, but not as I expected.

So for Fisheye, you simply add as a System Environment Variable FISHEYE_INST with a path, just like JAVA_HOME. The comment in crowd-init.properties says that Crowd Home can be run as a system environment variable. So people, like me, are trying to use Crowd.Home as a system environment variable, and it isn't working. I tried CROWD_HOME too; didn't work.

The link to the Stack Overflow article is what helped me. I edited the registry and modified the Options key at: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\Tomcat<X>\Parameters\Java (for 64-bit)

Dcrowd.home=C:\PROGRA~1\Atlassian\APPLIC~1\Crowd

My Crowd Home path is really C:\Program Files\Atlassian\Application Data\Crowd. The registry entry worked. Now when I upgrade Crowd by unzipping and replacing the files in the install folder, this is one less customization I will have to make.

Thanks.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

174 views 1 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you