Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crowd Apache integration causes php files to download rather than execute as a script.

Hello,

I'm trying to integrate a website validation using Apache with Crowd. Below is the code that I use to add the Crowd related lines into my apache config file.

<VirtualHost 11.22.33.44:80>
ServerName my.website.com
ServerAdmin webmaster@website.com
CustomLog /path/to/logs/access_log combined
ErrorLog /path/to/logs/error_log
DocumentRoot /home/user/www
DirectoryIndex index.html index.php

<Directory "/home/user/www">
# AuthName "Atlassian Crowd"
# AuthType Basic
# AuthBasicProvider crowd
# CrowdAppName appname
# CrowdAppPassword appapassword
# CrowdURL http://localhost:8095
#
Require valid-user

Options Includes ExecCGI FollowSymlinks
AllowOverride All
Order allow,deny
Allow from all

</Directory>
</VirtualHost>

The commented lines (beginning with #) are the ones that I added to integrate Crowd. Please note that the website works normally when these lines are commented out (of course no authentication is done with Crowd). When I uncomment the lines and restart Apache, it seems like the integration worked as Apache prompts me for a login/password using the 'Atlassian Crowd" realm as specified in the above config file. But after I login successfully, I'm being asked by Apache to download the index.php rather than execute it as a script. Do I have to set additional options other than what I have done above? Would appreciate any pointers on this.

Thanks,

Ravi

2 answers

This is embarassing. I think I solved by removing the

DirectoryIndex index.html index.php

line. Apparently that has something to with mod_authnz_crowd or something. Anyways, if there is anything I'm still missing, I'd appreciate a response.

thanks,

Ravi

I'm having the same problem.

By the moment i couldn't solve it.

My virtual host config is:

<VirtualHost *>

ServerName subdomain.domain.com

ServerAdmin admin_mail@domain.com

DocumentRoot /var/www

<Directory /var/www>

Options Indexes FollowSymLinks MultiViews

AllowOverride All

Order allow,deny

allow from all

AuthName "Atlassian Crowd"

AuthType Basic

AuthBasicProvider crowd

CrowdAppName appname

CrowdAppPassword appapassword

CrowdURL http://domain.com/crowd/

CrowdAcceptSSO On

CrowdCreateSSO On

CrowdBasicAuthEncoding UTF-8

CrowdTimeout 5

#CrowdCacheMaxAge 60

#CrowdCacheMaxEntries 500

Require valid-user

</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,

# alert, emerg.

LogLevel warn

CustomLog /var/log/apache2/access.log combined

</VirtualHost>

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Jira Cloud Performance Improvements

Hello everyone, I am a product manager in the Jira Cloud team focused on making sure our customers have a delightful experience using our products. Towards that goal, one of the areas which is extr...

175 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you