Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crowd 2.7.2 with LDAPS

We recently had to switch to LDAPS from LDAP. Using LDAP we would see less than 10 connections to the LDAP server. We applied the settings from KB article...

https://confluence.atlassian.com/display/CROWDKB/Performance+problem+when+using+LDAPS

We are still seeing connections shoot up to over 5000 connections to the ldap server and users can no longer login to the applications.

On the Connector tab we have tried the following combinations.

  1. ldap:// URL with SSL box ticked.
  2. ldaps:// URL with SSL box ticked
  3. ldaps:// without SSL box ticked

None seem to help. As soon as we switch back to ldap everything works fine...

Any idea's?

Thanks

Andrew

 

2 answers

1 accepted

0 votes
Answer accepted
Mallmann Atlassian Team Dec 18, 2015

Hi Andrew,

The reported problem might be related to this bug that got fixed on Crowd 2.8.2: https://jira.atlassian.com/browse/CWD-4070

I'd recommend you to set up a staging environment in which you could upgrade Crowd to 2.8.2 and verify whether the problem is replicable there.

 

I hope it helps! smile

Eduardo

We upgraded to 2.8.3 last night and it is working great now.

0 votes
Bruno Vincent Community Leader Dec 12, 2015

Hi Andrew,

Did you check the LDAP connection pool settings?

https://confluence.atlassian.com/display/CROWD/Configuring+the+LDAP+Connection+Pool

You might also want to set your own values in setenv.sh:

-Dcom.sun.jndi.ldap.connect.pool.protocol='plain ssl'
-Dcom.sun.jndi.ldap.connect.pool.authentication='none simple DIGEST-MD5'
-Dcom.sun.jndi.ldap.connect.pool.maxsize = <your_value>
-Dcom.sun.jndi.ldap.connect.pool.prefsize = <your_value>
-Dcom.sun.jndi.ldap.connect.timeout = <your_value>

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

168 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you