Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot reset/recover admin password

I am able to reset the password, but it doesn't look like anything is happening. I use the recently reset password and that is still doesn't work.

3 answers

0 votes
AnnWorley Atlassian Team Jul 12, 2018

Hi Elisa,

We will be happy to help you regain admin access to Crowd. Please verify you are logging into the Crowd console and not another application which uses Crowd to manage users.

Please let us know more about the steps you took to reset the admin password for Crowd. Did you follow Restoring Passwords To Recover Admin User Rights, for example, or did you change it another way?

Please let us know any error message you see in the browser when you log in.

Please check what error message is thrown in the <crowd-home>/logs/atlassian-crowd.log when the login fails. (Crowd Home is specified in the following file: <crowd_install_directory>/crowd-webapp/WEB-INF/classes/crowd-init.properties)

Thanks,

Ann

I also checked the crowd-init-properties file, and that does not have any errors. That just shows the path to the home directory.

AnnWorley Atlassian Team Jul 19, 2018

Hi Elisa, I meant to ask you to check the <crowd-home>/logs/atlassian-crowd.log for errors, and only mentioned the crowd-init-properties file in case you had trouble locating the Crowd Home directory.

I am getting the attached error message.

I follow the steps on the login page of the portal, to request a password reset link, got the email and follow the link there to change the password.Crowd-error.jpg

AnnWorley Atlassian Team Jul 19, 2018

Thanks for posting the screen shot. Based on the error message, I recommend checking for the two causes listed in this article: Connection to authentication server failed message when logging into Crowd after changing servers

As mentioned in cause 2 in the article, if you did not change the Crowd URL then the http timeout could be causing that error. Please see: Can't login into Crowd due to "Connection to authentication server failed"

Thank yo for the suggested articles

I am getting the same error message as on the second article. I have modified the crowd.properties file and increased the time out to 90000 from 60000. I just rebooted the server, but I am still unable to login to the portal.

AnnWorley Atlassian Team Jul 19, 2018

I am sorry to hear that. Please do check for errors in the <crowd-home>/logs/atlassian-crowd.log and let us know what you see. Please post the crowd.properties file, redacting any info you don't want to share publicly.

A few more quick questions:

  • Have there been any changes to the Crowd server since the last time you logged in?
  • Are any applications that are using Crowd for user management experiencing authentication issues?
  • I noticed it runs on SSL (https) - was that recently added?

Hello Ann,

it has been some time since I open this, but I am still having issue. I finally go to the DB and it is a MS SQL 

I followed the steps on https://confluence.atlassian.com/crowdkb/restoring-passwords-to-recover-admin-user-rights-283642653.html?_ga=2.145861494.356137194.1536607778-1011531749.1535655849

but I am still not have any luck 

 

To change the password to admin for a given username:

  1. Shut down Crowd.
  2. Connect to your database.
  3. Run the following SQL:

    update cwd_user set credential = '{PKCS5S2}8WEZjkCbLWysbcbZ5PRgMbdJgJOhkzRT3y1jxOqke2z1Zr79q8ypugFQEYaMoIZt'
     where id=<id from Stage 1>;
    
    update cwd_user_attribute set attribute_value = 'false', attribute_lower_value = 'false'
     where attribute_name = 'requiresPasswordChange' and user_id=<id from Stage 1>;
     
    update cwd_user_attribute set attribute_value = '0', attribute_lower_value = '0'
     where attribute_name = 'invalidPasswordAttempts' and user_id=<id from Stage1>;

JIRA.JPGI got an confirmation to recover the password, but I never got the mail with the link. What do i do?

 

Thanks!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

☕️ Monday coffee with Jexo: Weekly Atlassian news roundup | 21st June 2021

Hi community 👋, as every Monday we're bringing you a quick update on what happened in the Atlassian ecosystem last week. There were a few interesting events like for example the announcement of th...

68 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you