Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Applications won't authenticate with Crowd after moving to Windows Server 2016.

Hi,

We've been moving all our applications from a Windows 7 box to a Windows Server 2016 VM, and everything but Crowd has been easy.

Crowd boots just fine, and I can log in to it.

When I try to log into an application, the authentication fails.
The error I get is 

2018-11-07 13:00:17,538 https-openssl-nio-8096-exec-14 ERROR [[Catalina].[localhost].[/crowd].[default]] Servlet.service() for servlet [default] in context with path [/crowd] threw exception
java.lang.RuntimeException: java.net.UnknownHostException: 192.168.111.202:64309: invalid IPv6 address
at com.atlassian.crowd.manager.validation.XForwardedForUtil.getTrustedAddress(XForwardedForUtil.java:39)

This makes no sense. I have no idea why it's trying to parse an IPv4 address as IPv6.
I also have no idea what the port is.

To explain the set up, we have IIS running on a machine which reverse proxies to the Server 2016 box (192.168.111.202).

Crowd has an additional adaptor listening to port 8096, which has the SSL connection stuff in it, and the proxy pass. 

The original Windows 7 has both IPv4 and IPv6 enabled, which the Server 2016 box also has.

Does anyone know how to fix this?

I'm really struggling trying to find anyone with the same problem.

 

Kind regards,

Seb

 

1 answer

1 accepted

0 votes
Answer accepted

So I've worked out what my issue is.

In IIS, the Application Request Routing proxy settings have an option for including the TCP port from the client IP in the X-Forwarded-For header.

If I disable this, Crowd no longer views this as an IPv6 address, and works correctly.

My assumption is that the code is looking for the presence of the colon to determine if the IP address is IPv6. Because the port was included, this was tricking it into thinking it was.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

195 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you