Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

what does error rendering macro 'awp-include' mean?

The original page opens fine. I get this error when accessing from another Space

1 answer

1 accepted

0 votes
Answer accepted

It means what it says, it's tried to do what the macro is telling it to do, and it can't render the result for some reason.

Try editing the page, and then the macro within it - are the settings for the macro valid?  Does the preview work?

I do understand that it can't render the result from the page... I guess what I need to know is what is 'awp-include' in the error message? what's it refering to?

I can't find anything on the page that can give me an understanding of what the "awp" is refering to?

Thanks for weighing in on this issue. 

The page works but the preview doesn't work from the second page. 

I'm using a Tabs Container/Tabs page/Include page to read from the original page

The name of the macro is awp-include - it's an internal name, the error messages don't give us the human display name (not all macros have these)

Next thing I'd try is adding a new one to an empty page to see if we can find out where it is coming from - on a new page try typing {awp  if it really is a macro, it should start suggesting names.  Also try {include and see what that auto-suggests.

Thanks for the info... Also, you asked if the preview works... yes it works in preview. I just get the error message when viewing from the page.

Ah, ok, then we need to look at exactly what it is doing, and why it is choking on the content!  

One other thing I forgot - trying the { tests might help us identify it, but you might also want to quickly check admin -> user macros.  If it is a user macro, it should be listed with awp-include on-screen somewhere.

I ended up creating a new page and moved everything over to it. Apparently when I did that I didn't bring the macro in question with it so now the page renders correctly on both pages. Problem kinda solved (more worked around by remaking original page) but I'm up and running now. Thanks for the help .

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

🏑 Atlympic Event: Confluence

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

572 views 19 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you