Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

viewpdf macro is not working

Hi,

I'm using Confluence Cloud and I am trying to display a pdf using the viewpdf macro (documentation: https://confluence.atlassian.com/confcloud/pdf-macro-724765266.html) on a file that is attached to the same page.

The macro doesn't list the name of the file. Manually entering the macro also doesn't help.

{viewpdf:Colors.pdf}

 

Any ideas what's wrong?

 

Appreciate your help.

4 answers

1 accepted

0 votes
Answer accepted

Hello Shlomi,

Thank you for contacting us.

I am attempting to test this myself on my Cloud instance, but it seems to be working for me. Can you tell me if you have this issue with any PDF file and on all pages? Have you been able to test this with the new editing experience?

Regards,

Shannon

Hi Shannon,

I have the exact same problem.

I have checked with a few PDF files and also with the excel and powerpoint view macros and none of them show any files in the drop-down list. I have tried this both with and without specifying the page where the attachments are located.

This behaviour happens with the new editing experience.

Best regards,

Julian

Like # people like this

Hello Julian,

Welcome to Atlassian Community, and thank you for joining this conversation!

There is a bug for both the PDF macro and the Office macros where they are not able to fetch the attachments on the new editing experience:

  • CONFCLOUD-65753 Excel/Word/PPT Macro throws 401/403 errors when trying to fetch the relevant attachments on a page
  • CONFCLOUD-66870 Fabric PDF Macro does not see attachments on page

In Shlomi's example, he's using the wiki markup for the old editor in order to reference the attachment. It is not possible to reference macros in the new editor using the curly bracket. For this reason, I did not think he was using the new editing experience.

If you can confirm this problem is only with the new editing experience and not the old experience, then I can confirm you have run into the bugs above. Please click This affects my team and you will automatically be added to the list of watchers and receive updates on the bugs.

I hope that's clear, but do let me know if you have any questions about that.

Regards,

Shannon

Like # people like this

Thanks Shanonn,

I wasn't aware that the curly brackets are not relevant in the new editor. thanks for clarifying this.

 

Indeed, I am using the new editor, so I will track the bugs you mentioned.

 

Regards,

           Shlomi.

Shlomi,

No worries, happy to help!

Thank you for helping to report the bugs!

Regards,

Shannon

Nice that this is a known issue (from June - now we have November!)... anyway, I do not understand the mentioned "workaround":

Simply add add attachments to page with preview Icon.

Could someone elaborate? What is the "Preview Icon"?

 

BR
Andreas

Andreas,

Welcome to Atlassian Community. It's nice to have you!

I'm not quite sure what that was referring to, but I've updated the bug with the current workaround.  You'll want to attach PDF directly to the page and preview from there, rather than using the PDF Macro if you are still having issues with it.

As a note; my list of PDF attachments don't load on the page at first when I am trying to use that macro, but they appear after a few seconds, so see if the same happens for you.

Regards,

Shannon 

Thanks Shannon,

now I understand. Preview it without using the PDF Macro.

In any case, it is like you described. The attachment actually shows up eventually in the PDF macro's list - although it is not clear to me when exactly this starts happen ing!

 

BR

Andreas

Hi Andreas,

No problem! Thank you for bringing this to us again! I've updated the bug ticket to include that information in case users are experiencing the same delay.

Once your list of attached PDF files load, are you able to use the PDF macro as expected?

Regards,

Shannon

Yes. It does.

Maybe a new bug ticket: The "Edit" dialog of the PDF macro (and for that matter all the MS Office macros) does not open in the Apple Safari browser ...

 

BR
Andreas

Hello Andreas,

Thank you for letting me know that. As far as I am aware, Safari is not fully compatible with the Atlassian Companion app at this time due to the following bug:

  • CONFCLOUD-67604 Attachments macro: view and edit options don't work on Firefox and Safari

In the meantime, you can edit files with the latest version of Chrome browser.

Let me know if you have any questions about that.

Regards,

Shannon

Hi,

I'm not sure if I'm experiencing the same bug or a related one. I'm trying to preview a PDF on another page. When I'm editing the macro, I can see the PDF in the list of files fine, but nothing happens when I try to preview it in the preview section of the Edit macro dialogue box, and when I click on Save nothing happens. Is this the same bug or a different one?

 

Edit: I'm (currently) using Chrome version 78.0.3904.108.

Hi Alexander,

Nice to meet you! Welcome to Atlassian Community.

In this case, there's a spinning wheel when you try to either open the preview or edit when in Firefox or Safari. I assume you're in either one of those?

If you're not getting a spinning wheel, then we can confirm if you're running into the same bug by taking a look at your logs. You can raise a ticket with the Cloud Support Team and we can help determine the cause of your Companion app issue.

Regards,

Shannon

Hi Shannon, a few things

  • I'm using Chrome, not Firefox or Safari
  • I'm not trying to edit a file using the Atlassian Companion app. There's a PDF file attached to page A, and I'm trying to insert it on page B using the viewpdf macro. Both pages are in the same space.
  • When I try to do this using the macro, I'm able to find the PDF fine, but it won't display in the Preview pane, and clicking on the Save button does nothing (even though it's clickable). The edit PDF macro looks like this when I try to use it: viewpdf macro screenshot.png

I'll raise a ticket with support in any case.

 

Regards,

Alexander.

Like Jess likes this

Alexander,

Thank you for confirming that. I found your support ticket and I'll be watching it for the solution.

Please feel free to share the solution that worked for you here once it's resolved.

Regards,

Shannon

Thanks Shannon, I'll keep the thread updated.

In talking with support, it looks like this is a bug with the viewpdf macro, it's in Atlassian's list of bugs to fix: CONFCLOUD-67859: Can't insert pdf attachment in pdf macro .

Hi Alexander,

Thank you for the update! I'll include this thread on that case. I looks like it doesn't happen for every user, so we will need to investigate further to understand the cause.

I assume you're already watching it, but if not, you can click This affects my team and you'll receive email updates in the future about its progress.

Regards,

Shannon

Thanks Shannon, I'm watching the issue and another bug that I also encountered.

Like Shannon Spaniol likes this

I am seeing PDF and PPT macro issue atm. It worked on one page but now it fails on all

Alexandra,

Welcome to Atlassian Community! It's great to have you join us.

Could you elaborate on the issue you're seeing with PPT/PDF files? Is it the exact same issue here as in CONFCLOUD-67859? In that case, the issue is when the user clicks Insert, nothing happens.

If you are experiencing any other behavior, you can raise a new question here, or a ticket with Cloud Support if you are not on a free Cloud plan.

Regards,

Shannon

Hi Shanon, I don't get to press Insert for these macros as it's greyed out. Even if my file is attached to the page, the file drop-down has no files to select from, so looks like the macro is not retrieving the attachments?

Alexandra, 

In that case, you're likely being affected by one of the first bugs I sent in this thread:

When testing this, the only workaround I discovered was by dragging-and dropping the PDF onto the page, you can preview the PDF by clicking on the macro below:

Can you confirm if you're able to preview PDF attachments this way?

Regards,

Shannon

Hi Shanon, I had a ':' in my Page title and, following Stephen's advice below, it worked once i changed the title.

Like Shannon Spaniol likes this

Hi Alexandra,

Thank you for the confirmation!

Take care, 

Shannon

Greetings all - I've had this issue as well. I'd like to ask if the pages you have issues with this on have a colon in the page title. I've noticed that pages that have a ":" in the page title, the PDF macro will not show the list of attachments. Once you remove the colon, it works fine. 

Hi Stephen, neither of our pages has a colon in the title.

My Page title had a ':' in it and you're right - just changed the page title and it worked

Like Shannon Spaniol likes this

Is this still a known bug? The PDF macros will show me the list of attachments from a page, but nothing happens when I click "Insert".

Hello Teri,

Thank you for following-up here. You'll be able to see the status of the bug when you visit the link provided above. 

For example, the following bugs:

  • CONFCLOUD-66870 Fabric PDF Macro does not see attachments on a page
  • CONFCLOUD-67604 Attachments macro: view and edit options don't work on Firefox and Safari

Both of these are still in the initial stages, one during the data collection stage, and the other has been added to our short-term backlog.

I recommend clicking This affects my team to help us keep track of how many users are affected by these bugs. You can also watch the case and you'll receive updates via email.

Let me know if you have any questions about that.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

408 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you