setup wizard for Confluence 4.3.3 in ec2 fails

Hi,

I try to install confluence in ec2

I'm using a micro instance and a standard ubuntu 12.04/64bit AMI

The install goes well, the installation wizards gets the license key, asks for the database and dies after some minutes.

I tried the embedded database and PostgreSQL(9.1). The database connect worked, the wizard complained about already existing tables when I tried the install a second time.

There is no trace in the catalina or confluence logs. The server just dies :(

Could this be a resource problem in the micro instance?

Thanks for your assistance

Volker

3 answers

1 accepted

4 votes
Accepted answer

Hi Volker,

I have just been checking the specifications for an EC2 Micro Instance and I'm sorry to say that if the instance you are referring to has the following specs, taken from the EC2 site, then it is insufficient for running Confluence:

Micro Instance
613 MiB memory
Up to 2 EC2 Compute Units (for short periodic bursts)
EBS storage only
32-bit or 64-bit platform
I/O Performance: Low
EBS-Optimized Available: No
API name: t1.micro

Realistically, Confluence requires 768MB of memory and this would be in excess of the resources required by the Operating System and other applications required by Confluence, (such as the database, web server etc). Therefore, my suggestion based on the current EC2 options would be to migrate to a "Small Instance", as this is the next option up and it has the required specs to run Confluence satisfactorily.

Small Instance
1.7 GiB memory
1 EC2 Compute Unit (1 virtual core with 1 EC2 Compute Unit)
160 GB instance storage
32-bit or 64-bit platform
I/O Performance: Moderate
EBS-Optimized Available: No
API name: m1.small

I hope this suggestion helps, because I don't believe your current instance has enough resources to successfully run Confluence.

All the best,
John

Just for info, I also switched to PostgeSQL 8.4

Volker

Thanks John

I switched to m1.small and confluence worked like a charm

Now I'm stuck with Jira, but that's another problem

Thank

Volker

Note that PostgreSQL 9.1 is not supported in confluence (see Confuence Supported Platforms). There is a improvement request to add support for PostgreSQL 9.1 in CONF-25354.

When looking for errors is normally better to look in Confluence logs located in <CONFLUENCE_DATA>/logs/atlassian-confluence.log.

That's weird, I never saw anything like that before.

I would suggest to download another SQL vendor, like MySQL for example.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

60 views 3 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you