After upgrading Confluence to 7.8.0 and MySQL from 5.7.x to 8.x, we are seeing this error in our logs.
ERROR [http-nio-127.0.0.1-8090-exec-93] [plugin.descriptor.web.ConfluenceWebInterfaceManager] getHtml Failed to render web panel: com.atlassian.plugin.web.descriptors.DefaultWebPanelModuleDescriptor$ContextAwareWebPanel@1d4e865b
-- url: /display/DD/Decision+log | traceId: 4f913c631079d71d | userName: malc
com.atlassian.activeobjects.internal.ActiveObjectsInitException: bundle [com.atlassian.confluence.plugins.confluence-feature-discovery-plugin]
...
Caused by: java.lang.RuntimeException: Could not read fields for table AO_6384AB_DISCOVERED
...
Caused by: java.sql.SQLException: Index column size too large. The maximum column size is 767 bytes.
We are seeing this error when attempting to create a new page from a blueprint and when trying to create a new space. This type of error seems to be related to Unicode handling in the database. I have used the directions on How to Fix the Collation and Character Set of a MySQL Database manually (twice!) and there are no additional databases, tables, or columns that need to have their metadata changed.
We are using AWS for hosting—dedicated EC2 and MySQL RDS instances for Confluence. The complete runbook for the upgrade is posted on our Jira instance. (It includes the steps in the "Fix the Collation" document above.)
Our local issue tracking this problem is FOLIO-2867. It has the troubleshooting steps we've tried so far. Are there suggestions for things we can try to fix the issue?