"You are not permitted to perform this operation."

This is driving me potty. I've got full administrator permissions to a live instance of Confluence, but quite often when I try to edit certain pages I get the error "You are not permitted to perform this operation.". This despite the fact that I'm in a group with god powers over the space (green ticks along the board). Even if I give my own user god permissions to the space, I still get the error. No restrictions are defined on the pages. The hyperlinks in the breadcrumbs above "Not permitted" are "Administration / Users". 

We're using v5.8.9

I'm not after a diagnosis of the problem, as this is a highly-customised installation with lots of bespoke code and plugins, although if this does ring a bell with folk I'd be interested in your thoughts. What I do need to know is: how can I determine what "operation" I'm "not permitted to perform"? Do I have to go into the server logs, and if so which ones?

Thanks in advance... smile

5 answers

This widget could not be displayed.

Thanks to all for your replies. I did try replying yesterday but couldn't comment because I didn't have enough 'points', and when I tried to answer I got a "You are not permitted to perform this operation." - D'OH!!

Jobin: it's happening all over. Interestingly, if I SU as a lesser user, I can edit pages.

Guilherme: this is a complex, customised live system, so I can't carry out such diagnostics, sensible as they are.

Anne: No, there are no restrictions anywhere.

I strongly suspect that the permissions problem is related to the authentication method (Shibboleth) that we're using, but as I mentioned in my initial post, it's not a problem diagnosis that I'm after (else I'd email support directly as we're paying customers) but rather a way of finding out what the flip the permissions error refers to. As a founder member of CREM (Campaign for Real Error Messages), it's very frustrating to not know what "operation" I'm "not permitted" to carry out, and what page/space the "operation" is banned on. Is there a way of finding this out, perhaps by tailing a log file?

Here's hoping that I'm allowed to post this answer...

Just one quick comment. Being a Confluence Admin doesn't grant you access on the individual spaces. You have to add yourself into those space permissions.

This widget could not be displayed.

Hello all

Thanks for your replies. I tried to post an answer yesterday but was bounced back by the server, probably because I don't have enough points on Answers (I'll try to build those up by being a bit more helpful in other threads). With the help of our Confluence server admin, the main problem has been diagnosed, and basically it was a username mixup. He did also say that there might be a way of making error messages a bit more meaningful but he didn't go into detail, so does anyone here know where in the system config I can tweak errors so that they report what's happened, and to which space/page? This would also be useful for customising 404s, say.

This widget could not be displayed.

Is this happening all over the space or only on specific pages? Are those pages restricted by any chance?

This widget could not be displayed.

Hey Fred,

You need to isolate the case so you could be able to find the root cause. Since you've commented that your instance is customised, I'd try the following troubleshoot first: 

* Themes: See which theme you're using, switch back to the default if you're not using it already.
* Layouts: See if you have any custom layout defined, if yes then make a backup and reset to default.
* Stylesheet: See if you have custom stylesheet, if yes then make a backup and reset to default.
* Custom HTML: See if you have any custom HTML defined, if yes make a backup then reset to default.

What Confluence's version are you using right now?

Cheers,

This widget could not be displayed.

Are the pages you're trying to edit - I suppose that's what you want to do - restricted individually resp. children of a page restricted individually?
If so even god power won't work. The idea behind that is that someone can restrict a page and that even as confluence admin you're not supposed to have editing rights then.

What you can do is give yourself editing rights for the page you want to edit. If that doesn't work check the motherpage for restrictions and adapt it accordingly.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

406 views 4 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you