"What’s New in Confluence..." popup blank in FF

For somereason I can't figure out, the "What’s New in Confluence..." popup tries to request HTTP version of the page which then redirects to HTTPS. By default Firefox blocks the HTTP request since our wiki is using SSL, so the user isn't seeing the content at all. This is happening in our environment both with version 5.1.5 and 5.2.5. Is there something I'm doing wrong?

3 answers

1 accepted

It works, thanks for putting me on the right track Kai. Just did a global replace in help-paths.properties file for "=" with "=confluence.atlassian.com/display/CONF53/" and then customised the whats new entries to:

help.whats.new.iframe.link=www.atlassian.com/en/software/confluence/whats-new-iframe/53
help.whats.new.full.link=www.atlassian.com/software/confluence/whats-new.jsp

E.g. the top of my help-paths.properties file looks like this (note I decided to skip straight to confluence.atlassian.com and avoid docs.atlassian.com altogether)...

help.prefix=https://{1}

## Page Names
help.creating.content=confluence.atlassian.com/display/CONF53/Creating+Content
help.content.report.table.macro=confluence.atlassian.com/display/CONF53/Content+Report+Table+Macro
...

One caveat I've noticed is that it breaks the "Online Help" link, which changes to https://getting+help+and+support. There doesn't seem to be an entry for this page anywhere in help-paths.properties. I tried to track down what generates the link in the vm templates and hit a reference to aui.page.header.soy which I imagine must be in a jar file somewhere. I think I'll just hack it with some javascript.

A grep on the source revealed that I needed to add this entry too...

urlsuffix.help.page=confluence.atlassian.com/display/CONF53/getting+help+and+support

Hi Sam,

congrats to this teamwork. With your documented information we were able to fix both challenges.

To say this quite clear: Although being a huge atlassian fan, I'd like to point out that this mixed-content-problem took us more than two mandays (!) just because of one (!) missing "s" in the link (http instead of https). This makes me think twice considering further updates. Shame on this broken process!

Cheers
Kai

Well, I think this is the first Confluence bug report I've ever made that got promoted to Major and though it doesn't make sense to me why it's not caused issues for clients and got more votes. I'm sure they'll fix it one day. I can only postulate that most clients that care about security and use SSL disable "What's New" for security reasons.

Thanks for spending some time on it. I reluctantly just disabled "What's New" due to this issue. Now I can reenable it on our 5.3 upgrade with this - really flakey - workaround. I can't understand why it's so hard for someone to fix the silly redirect from https://docs.atlassian.com to http://www.atlassian.com and then finally to https://www.atlassian.com for the what's new thingy. Though who knows, behind the scenes they might have their reasons.

So I found the documentation regarding extracting help-paths.properties into confluence/WEB-INF/classes/ in order to amend the help documentation path. This allows me to specify:

help.prefix=https://docs.atlassian.com/confluence/docs-{0}/{1}

Unfortunatly, the atlassian hosted "What's New" page redirects to an http URL that still causes errors...

https://docs.atlassian.com/confluence/docs-52/whatsnew/iframe

redirects to...

http://www.atlassian.com/en/software/confluence/whats-new-iframe/52

which redirects to the SSL version...

https://www.atlassian.com/en/software/confluence/whats-new-iframe/52

This is mental and very frustraiting!

Update: I've logged a bug report for this here so I can close this question and stopped getting spammed by the "Open question reminder"... https://jira.atlassian.com/browse/CONF-31065

Just a short comment/hint from our side, how we solved this annoying challenge quite easy - and not yet documented:

1.) Create new/empty file "help-paths.properties" in directory .../WEB-INF/classes/ (!)

2.) Enter following content in the file:

help.prefix=https://docs.atlassian.com/confluence/docs-53/whatsnew/iframe?e=Y2FybG8uaG9oZW5icmlua0B4aW5nLmNvbQ%3D%3D&od=false&a=true
help.whats.new.iframe.link=whatsnew

3.) Save file

4.) Restart Confluence

Done! This helps a lot as you do not have to search and extract within/from the JAR-file (the file "help-paths.properties" was not present in our installation.

Hope this helps you!

Cheers
Kai

I'll try this, but I'm concerned that this will break all other "Help" links throughout the system.

I've updated my question because I noticed I had the wrong redirected URLs (must have failed to copy/paste correctly). The problem is it redirects to http://www.atlassian.com... before finally redirecting to https://www.atlassian.com...

I've tried a variation of your workaround to land directly on the final destination page, and now "What's New" works perfectly, however any other links to Confluence Help are broken.

You've given me an idea though, perhaps I could set the prefix to simply "https://" and then put the full path including the domain in for every entry in the packaged help-paths.properties file.

I have placed this Help-paths.properties file under WEB-INF/CLASSES folder but still when my site is up i am not able to see anything. I have inspected the frame and it shows Url is pointing to null.

So any help....

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted yesterday in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

129 views 3 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you