Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Placeholder" macro text doesn't show up when using "Create from template"

I have a template that uses the "placeholder" macro copiously. And I have a "create from template" macro configured so that when users hit it they get to use that template to create a new page.

However, when they hit "create from template" what they see has none of the placeholder text visible, which makes it very hard to know what to fill in to the various "variable" macros. If the user saves the page they just created, and then edits it, all the placeholder text shows up.

What am I doing wrong that is preventing placeholder text from showing up under "create from template"?

1 answer

0 votes
Diego Atlassian Team Nov 19, 2020

Hello @David Cantrell!

As I understand, the contents of our “Placeholder” macro does not show up as soon as the page is created using the “Create From Template” macro.

To test this, I created a new template in my Confluence site. Here is what it looks like:

Screen Shot 2020-11-19 at 11.37.22.png

After that, I created a new page and placed the “Create From Template” macro in it. Here is what it looks like:

Screen Shot 2020-11-19 at 12.10.45.png

After that, I tried using the “Create From Template” macro. Here is what I see:

Screen-Recording-2020-11-19-at-1.gif

I also tried to do the same using “Instructional Text” with our Legacy Editor template. Even there, the placeholder text was present. Here it is:

Screen-Recording-2020-11-19-at-1(1).gif

With these results, I would like to ask you a few questions. Here we go:

  1. What browser are your users using when they to use the “Create From Template” macro?
  2. Is this present regardless of the template to which the “Create From Template” macro points to?
  3. Is this happening only with newly created templates or only already existing ones?

Let us hear from you!

The placeholder text is missing in both Chrome and Firefox, and AFAIK we're only using placeholders in one template, which I just created a couple of days ago.

We have now raised a ticket with Atlassian support, who have access to the template in question, so in case anyone else has the same problem in the future I will report back with their solution.

The "solution" is that this is broken as designed and so won't be fixed. <sigh>

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

59 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you