Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Edit Contents" and "Edit" on the same page

Can someone pleas help me on whether I should see both "Edit Contents" and "Edit" menu functions on the same page I write? I double-checked and it seems this is the only page where both menu options are available.

This page was created using a template but I cannot see the "Edit Contents" option visible at other similar pages that I also created from templates.

Can I remove/resolve the "Edit Contents" somehow to see only the "Edit" function again?

Thanks you.

5 answers

1 accepted

0 votes
Answer accepted

Hi all,

Thank you for all of your help to resolve this.

I recently found the following while I was searching through various support community pages at Atlassian: https://jira.atlassian.com/browse/CONFCLOUD-73213

This confirms that the Spellchecker module of Chrome v96-97 (and probably it is the same with Microsoft Edge) slows down editing pages in Confluence significantly.

After disabling the Spellchecker in Chrome’s configuration, Confluence works like a charm..

Since then several colleagues of mine raised the same performance issue and they all were resolved by disabling the Spellchecker module in Chrome.

I guess at the end of my work I still need to enable the Spellchecker temporarily to fix my typos. But the issue is solved until Google fix the Spellchecker module.

Hi @Norbert Murzsa,

Welcome to the community. This is Iman from ServiceRocket.

If you are familiar with our Scaffolding add-on, anytime there are any Scaffolding macros in the page (whether created from a template or added directly to the page), the Edit Contents button will appear for the page. The Edit Contents button allows users to enter data into Scaffolding fields.

If you wish to remove this button, you would need to remove the Scaffolding macros from the page/template.

In addition, we would like to share our our Scaffolding Evaluator's Guide which covers add-on's full functionality and helps to understand how Scaffolding can improve your use of Confluence.

If you have any questions or need further assistance implementing your use-cases, you can always reach out to our live chat support or send an email to apps.support@servicerocket.com.
Best,
Iman

So, I almost a newbie in Confluence. Of course I've been creating/editing pages for years but have never created a template and apart from some macros I did not dig too deep in Confluence. As I have multiple response (that I appreciate) I use @Fabian Lim response to add more content. Any help is appreciated.

0 votes
Laura Holton Community Leader Dec 21, 2021

Hi @Norbert Murzsa 👋

Welcome to the Community! That definitely sounds a little odd, echoing @Fabian Lim if you could share what you're seeing it'll be easier for us to hopefully help.

Additionally, if you are using Linking for Confluence and Scaffolding templates it might be worth reaching out to the ServiceRocket support team here.

I hope this helps but if you have any other questions just ask away 😃

All the best,

Laura

0 votes
Olga Videc Community Leader Dec 20, 2021

Hello @Norbert Murzsa 

Since I'm not familiar with the "edit content" button did a little digging and found this, maybe can help.

"

It sounds like you're using Linking for Confluence and Scaffolding templates (both are ServiceRocket apps). The Add Page via Form macro (from Linking app) will enable the one-click page creation with a pre-defined template, with the option to have the template made out of Scaffolding macros. That's what triggers the Edit Content button to appear. 

To troubleshoot, I'd first check if the Add Page via Form macro settings has "Live Template" checked. This setting should only be used with Templates with Scaffolding macros on them. If you are using one of the pre-supplied templates, you don't need to have the Live Template setting checked.

"

BY -Monique
ServiceRocket team

From: https://community.atlassian.com/t5/Confluence-questions/How-to-edit-page-created-from-a-template/qaq-p/1541604

 

BR, Olga

0 votes
Fabian Lim Community Leader Dec 20, 2021

Hi @Norbert Murzsa

Welcome to the community!

Can you share a screenshot of what you see in this template?

Regards

Capture.PNGIt seems that this might be related to template management but I can edit my page via both Edit menu options.. while I only have the "Edit" option for all other pages.

So the original template should be fine as this is one of our standard templates and everyone in the team uses it with no issue.

I also created my document from this template and it worked fine until I copied a few lines in to it from another Confluence page. Than it became extreme slow (need to wait 15-30 seconds to see a sentence I've just typed in).

If a create a new page from the same template and start to write in it something, I cannot see the "Edit Contents" option but "Edit" only... but it still slow.

So I used this new page and copied my original material in to it but as long as I saved it.. it shows the "Edit Contents" option again becomes really slow.

If a create a document (not from template using my Personal Space the performance is good. The performance issue doesn't seem to affect the other users but my one only.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

🏠 Say hello to the new Confluence Home!

Hi Atlassian Community, My name is DJ Chung, and I’m a Product Manager on the Confluence Cloud team. Today, I’m excited to share a new and improved version of Home. The new Home helps you ...

43,877 views 33 137
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you