problem with running Confluence with nginx.

We have a problem with running Confluence with nginx.

Confluence and nginx on one server.

Local address: 192.168.1.37
External address: doc.rubetek.com

Our nginx config:
server {
             listen 80 default;
             location /confluence {
                 client_max_body_size 100m;
                 proxy_set_header X-Forwarded-Host $host;
                 proxy_set_header X-Forwarded-Server $host;
                 proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                 proxy_pass http://192.168.1.37:8090/confluence;
                 }
              location /synchrony-proxy {
                 proxy_set_header X-Forwarded-Host $host;
                 proxy_set_header X-Forwarded-Server $host;
                 proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                 proxy_pass http://192.168.1.37:8090/synchrony-proxy;
                 proxy_http_version 1.1;
                 proxy_set_header Upgrade $http_upgrade;
                 proxy_set_header Connection "Upgrade";
                 }
}
======================================
In
/opt/attlasian/confluence/bin/setenv.sh
We added:
CATALINA_OPTS="-Dsynchrony.proxy.enabled=true ${CATALINA_OPTS}"
=============================
In
/var/atlassian/application-data/confluence/confluence.cfg.xm
We added:
<property name="synchrony.proxy.enabled">true</property>
===========================

Our server config:

/opt/attlasian/confluence/conf/server.xml

<Server port="8000" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"
proxyName="doc.rubetek.com" proxyPort="80" />

<Engine name="Standalone" defaultHost="localhost" debug="0">

<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false" startStopThreads="4">
<Context path="/confluence" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
<!-- Logger is deprecated in Tomcat 5.5. Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->
<Manager pathname="" />
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
</Context>

<Context path="/synchrony-proxy" docBase="../synchrony-proxy" debug="0" reloadable="false" useHttpOnly="true">
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60" />
</Context>
</Host>

</Engine>

==============================

But, when we launch confluence editor,
One script file, will have url: http://192.168.1.37:8090/synchrony-proxy/resources/js/vendor/sockjs.min.js
(on screenshot)

2017-08-17 14.38.39.jpg

Because of this doesn't work confluence editor.


Whats is this our error? Or maybe bag?

1 answer

0 vote
Ann Worley Atlassian Team Aug 18, 2017

Please make sure the Base URL is set to http://doc.rubetek.com.

The server.xml you posted looks fine as far as proxyName and proxyPort.

Please check your configuration against these 2 documents:

Troubleshooting Collaborative Editing

How to use NGINX to proxy requests for Confluence

I look forward to hearing what you find.

How to change base url if we don't have system-administrator user? Where is this settings option stored, Is it somewhere in
the configuration files or in the database? We have h2db.h2.db database

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

628 views 21 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you