Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,373
Community Members
 
Community Events
176
Community Groups

paste unformatted

Edited

Is there a way to paste unformatted text in confluence wiki?

Normally CTRL-SHIFT-V does it in other programs (like this form), but that doesn't paste anything in the confluence wiki pages.

 

3 answers

1 accepted

3 votes
Answer accepted
Shawn C Atlassian Team Sep 20, 2018

Hi Derrick, 

I'm afraid that the Confluence Editor does not allow us to 'shift paste' to add unformatted text as it's mapped to the "Paste Table Rows" function. 

There is a Feature Request to change this functionailty: https://jira.atlassian.com/browse/CONFSERVER-28229

As a workaround, you can disable Paste Table Row module so that it'll instead paste content as plaintext:

  • Go to Confluence Administration and Locate the Manage Add-ons/Plugins 
  • Change the 2nd Dropdown to "System" and Search for "Confluence Keyboard Shortcuts Plugin"
  • Expand the Selection, expand Modules
  • Locate "Paste Table Row (tinymce.table.paste.row)" and disable it

Disabling this Module will impact your ability to Paste Table Rows via keyboard shortcut, but the function will still work by clicking on the button on the toolbar.

PasteTableRow.png

If it's not something that we can disable, we'll need to paste the content into a plaintext editor and then copy/paste it from there. 

Regards,
Shawn

Thanks for the information Shawn.

It seems this has been a bug since 2013 but nobody has bothered to fix it. That has to be a record.

I don't have administrator rights, so I can't use your suggested fix. Instead I'll paste it into a real editor and then copy the plain text, then paste it into the Confluence editor.

Like # people like this

@curmudgeon You can use right click and Paste as Plain Text in Chrome - that way it is still super annoying but at least faster.

@Shawn C is this option not available in the cloud version? I have admin rights but it shows "Module cannot be modified". Any other way to change it?

I have the same issue. I have admin rights but Paste Table Row states "Module cannot be modified".

This bug goes well beyond annoying - it's extremely expensive as it doubles the time to do nearly every data entry task in Confluence.

Like Michael Davé likes this

The keyboard-only solution I use for plain text pasting within a Confluence page is to first paste and cut via the Search bar (still annoying but slightly more productive than using the mouse):

  • Cmd+F (pause for half a second or however long Find bar takes to appear)
  • Cmd+V
  • Cmd+A
  • Cmd+X
  • Esc
  • Cmd+V

(Replace Cmd with Ctrl for Windows)

Like # people like this

You can also do the following in Chrome:

    Right click, click "Paste as Plain Text" (The hotkey won't work as outlined in this issue)

For the plugin, "Paste Table Row (tinymce.table.paste.row)" Is it possible to change the hotkey instead of disabling it?

I'm looking forward to a solution to this too. Half the content I'm entering into Confluence is copied from PHPStorm. I can't ctrl+v because it brings in the IDE's formatting, so I have to continually right click -> Paste as plain text.

Like Nathan Lowe likes this

I've shared a Javascript bookmarklet that you can use to disable the Confluence editor override of Ctrl-Shift-V in this answer:

https://community.atlassian.com/t5/Confluence-questions/Re-Is-there-a-shortcut-for-Paste-as-Plain-Text-in-Chrome/qaq-p/1324995/comment-id/170523#M170523

"you can disable Paste Table Row module..."

What do I do if I'm not an administrator?

Atlassian seems to specialize in breaking all manner of records for fixing bugs.  I've worked in the computer industry for 30 years and I have yet to see this level of dysfunction and utter contempt and disregard for customers.  Its ironic that they design tools to enable Agile and yet fail to even consider one of the basic 4 principles of the Agile Manifestor namely "Responding to customers over following a plan".

I wonder why companies pay for products to a company that has such callous attitude to its customers.

Like granticusiv likes this

On Macs, there is a built-in MacOS feature to paste plain text, by removing original formatting. The hotkey combination is Command + Option + Shift + V
The command works independently of the text origin and insertion destination.

This works perfectly in MacOS ... and is way better than having to have admin rights (I mean really?!) or switching browser (again, really!?).

All you have to do is maybe switch OS o_0  

Again, WTH Confluence?  

I cannot get any of the above suggestions to work, but I found a trick that seems to work:

- From the Insert menu, select "Code Snippet"

- Paste your text into it: It will be inside a gray box with line numbers.

- Go to the beginning of the gray box (i.e. inside the box right after "1" in the first line).

- Hit "Delete" key twice: it removes the gray box and the line numbers, and your text remains unformatted on the page, as it should be.

@risto Thanks. it worked for me

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events