Hi,
We need to create a ditto copy of our Confluence production server which has a huge amount of data. We want to do it for our test purposes. To achieve this, we followed below process.
1) Copied the existing app folder to new server at the same path.
2) Copied database (Oracle 12C) to a new server and gave it a new name.
3) Installed Confluence (same version, 7.1.2) on new server.
4) Set application-data in new installation
5) modified the confluence.cfg.xml file to reflect new database name.
After this we started Confluence on new instance. It starts and we are able to open it. But we are not able to login into it.
In the logs it gives lots database related errors. Like below:
*****************
Caused by: Error : 955, Position : 13, Sql = CREATE TABLE "AO_7CDE43_SERVER_CONFIG" (
"CUSTOM_TEMPLATE_PATH" CLOB,
"DEFAULT_USER_ID_TEMPLATE" VARCHAR(255),
"ENABLED_FOR_ALL_USERS" NUMBER(1),
"GROUPS_WITH_ACCESS" CLOB,
"ID" NUMBER(11) NOT NULL,
"NOTIFICATION_MEDIUM_KEY" VARCHAR(255),
"SERVER_NAME" VARCHAR(255),
PRIMARY KEY("ID")
), OriginalSql = CREATE TABLE "AO_7CDE43_SERVER_CONFIG" (
"CUSTOM_TEMPLATE_PATH" CLOB,
"DEFAULT_USER_ID_TEMPLATE" VARCHAR(255),
"ENABLED_FOR_ALL_USERS" NUMBER(1),
"GROUPS_WITH_ACCESS" CLOB,
"ID" NUMBER(11) NOT NULL,
"NOTIFICATION_MEDIUM_KEY" VARCHAR(255),
"SERVER_NAME" VARCHAR(255),
PRIMARY KEY("ID")
), Error Msg = ORA-00955: name is already used by an existing object
***************
It seems it is trying to re-create all the tables. Can someone please guide as what wrong are we doing here. We just want to create a mirror image of Confluence server. Instead of using Confluence's own backup-restore function. We are trying to use direct copy from server to server and db to new db.
Regards
Sanan