It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

how do I indent text?

I have created a page and the Indent / Outdent buttons are greyed out?

 

How can I indent my text?

4 answers

1 accepted

0 votes
Answer accepted

There is no answer to my question other than:

I tried on my Cloud instance and saw the same behavior. It looks like it has been that way since December 2017: Ability to Indent block elements such as paragraphs, headings, and block quotes

I created a Greasemonkey/Tampermonkey/Violentmonkey script.
It re-enables the indent and outdent buttons while editing.
confluence-indent-enable.js

I big thank you to Ricky Vincent that provided the solution for the script loading issue in CONFCLOUD-58656

Every "text edit widget" on the web i have used since 1999, has an "indent" feature as standard... please fix this!

Altassian Team: Cannot claim you offer a field where to write specifications if you can't indent, you have speech recognition in the description field of the story..., can you please just fix that basic shortcoming? Version 1 and just about any other tool let's you.

0 votes
AnnWorley Atlassian Team Jan 29, 2018

The indent/outdent buttons will be greyed out if the cursor is in a field that cannot be indented or outdented. When you first create a page the cursor is in the Title field, which is one of those fields.

If you have the cursor on a blank spot on the page, then are the buttons enabled? Feel free to attach a screen shot if that will help show the issue.

Do you know if you are on Cloud Confluence or if it's server, what version? The version is usually at the bottom of each page, "powered by Atlassian <product, version>".

I edit the page and place the cursor where the red line is, notice I can "outdent", but the "indent" button is grayed out.

Indent_disabled.PNG

We are on the cloud:

url.PNG

Here is a New Blank Page, my cursor is at the END of the text ...

( I am NOT editing the title of the page )

notice indent and outdent are grayed out:

 

newBlankPage.PNG

AnnWorley Atlassian Team Jan 29, 2018

I tried on my Cloud instance and saw the same behavior. It looks like it has been that way since December 2017: Ability to Indent block elements such as paragraphs, headings, and block quotes

We disabled the ability to create new indents. Your existing pages with indented text are safe and you can still edit this text and outdent it, but you just won't be able to indent further.

Please comment or vote on the suggestion ticket linked above to communicate directly with the development team. Doing so will add you to notifications, and help emphasize your use case.

This ticket has been closed but it is not possible to indent bulleted lists in the editor today. Is this because of the update in page editors or was this never fixed? 

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

306 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you