It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

confluence mobile app doesn't work on Android phone

We tried android app to connect our confluence-server ,also show can't get a secure connection, we have tried to install the cert but still doesn't work, our server has a public cert and trusted by default, so IOS version can directly use the app.

 

It seems that the app haven't tried to connect to the server at all.

I tried to use the latest version 0.1.40  on two different phones,one is HuaWei and another is Xiaomi

 

Android version is 8.0

Anyone can help?

 

2 answers

0 votes

Hi there,

Provided you've met all requirements in Confluence Mobile documentation and you're running 6.8 or higher, it should work.

Is there error message the one you're getting from the below article?

I assume this is the article you saw since you mentioned installing the certificate, but I want to verify. Please review it and let me know if you meet all the requirements listed there.

Regards,

Shannon

Hi,Shannon

Thanks for the quick reply.Below is some snapshot.

2018-06-29 09.02.12.pngWechatIMG615.jpegWechatIMG616.jpegWechatIMG617.jpeg

Sorry for all Chinese part since most our users are Chinese.Our website has a regular cert from godaddy so I don't think we need install any cert on mobile device.You can see we visit the https link directly through chrome on the computer show security icon.Also for IOS devices,the app works well.But Android version it always show problem,Both Huawei and Xiaomi we tried.To check I installed our cert on my phone,but nothing changed.It seems like the android version didn't try to connect the website at all then directly show cannot get a secure connection.

Thank you and apologies for the delay.

I want to take a deeper look at this so I have created a support ticket for you. Our team will review it and get in touch with you with any more information.

Regards,

Shannon

Damien_Tan Atlassian Team Jul 12, 2018

hey @zhijie.fang

I see Shannon has created a support ticket for you regarding this issue and I've worked on it and gotten some clue as the SSL Cert doesn't seem to be correct. I've shared my findings with you in the ticket but haven't gotten your reply thus far. I wonder if you've received my reply from the support ticket.

You can check it in the link below after logging in:

https://getsupport.atlassian.com/servicedesk/customer/user/requests?status=open

Hi,

I have exact the same Problem. The app works on our IOS devices but on our android devices i have the same problem as described above with one differnce.
When i try to connect the first time everything works fine. When i then close the app it can't connect with the error "Can't get a secure connection". When i now try to connect to our test server i will see the login to the test server. Then i cancel the login and can now connect again to our production server. After closing the app a new connection to the production server won't be possible.
Please can you tell what the solution is?

Regards
Katja

Hi,

i had to configure the whole chain in Apache on the reverse proxy with SSLCertificateChainFile /etc/apache2/ssl-chain.crt and not just the intermediate certificate. Because it is not a self signed certificate and every browser and IOS is fine with my certificate i didn't expect this.

Regards
Katja

Katja,

Thank you for the follow-up on your solution. I am speaking with the team right now to see if this is a known issue. I will follow-up with you on Monday with my findings!

Thank you for your patience.

Regards,

Shannon

Hello Katja,

I spoke with the team, and it seems there's a known issue for Android where you have to install the intermediate cert on the server itself to get it to work.

Can you confirm if that's the issue you ran into? 

Regards,

Shannon

Hello Shannon,

yes that exactly describes my problem.

Regards

Katja

Katja,

Thank you for confirming that. 

Unfortunately the requirement comes from Android itself. This page below describes some common issues which are Android specific. In this case, you're affected by Missing intermediate certificate authority

I hope that clarifies things even further, but I am happy to hear you were able to get your cert working with your Android device.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

327 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you