confluence macro $body

Hi all,

I have what should be an easy one, but I cannot seem to get it.  I am trying to write a stack overflow type of highlight and the body is showing as "$body" instead of the actual contents of the body?!? Here is what I wrote:

## Macro title: highlight
## Macro has a body: Y
## Output: HTML
## Body processing: Rendered
## This makes the body text look like inline code markup from stackoverflow
## @noparam

<span style="padding: 1px 5px 1px 5px; font-family: Consolas, Menlo, Monaco, Lucida Console, Liberation Mono, DejaVu Sans Mono, Bitstream Vera Sans Mono, Courier New, monospace, serif; background-color: #eeeeee;"> <ac:rich-text-body>$body</ac:rich-text-body> </span>

Thanks in advance,

Robert

1 answer

1 accepted

NM the button above was set to no body.  Rough day sorry...

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

390 views 17 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you