Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

confluence.browser.language.enabled not working

Hello,

I added

confluence.browser.language.enabled = false in the setenv.sh file et deleted cache / restarted the server.

But the interface still detect the browser settings and not my default language set in the admin interface of confluence.

 

Thank you for your help

1 answer

1 accepted

1 vote
Answer accepted

Hi @Christian Kai 
I hope you are well.

According to Choosing a Default Language , the language preference is ruled by the following configuration:

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

  • The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
  • The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too. 
  • The language set in your browser. The browser sends a header with a prioritized list of languages. Confluence will use the first supported language in that list. Confluence administrators can disable this option by setting the confluence.browser.language.enabled system property to false.
  • The default language for your site, as defined by your Confluence site administrator.

 

Make sure the two options above are not associated to your profile before testing the system property.

The full entry in setenv.sh should look like the below.

CATALINA_OPTS="-Dconfluence.browser.language.enabled=false ${CATALINA_OPTS}"

How's it configured in your instance?

I hope that helps.

Kind regards,
Thiago Masutti

I don't have the "-D" before the entry confluence, i will test and tell you if is okay.

 

Thank you

Ok, it seems to be good with "-D", you should update the documentation with this.

 

Thank you

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Confluence

Miss the Confluence demos at Team 21? Watch them here!

Phew, Atlassian Team 2021 blew by. With dozens of demos and a handful of keynotes, you may have missed some of the awesome Confluence Cloud sessions. Don't' worry, you can watch them all here or on Y...

145 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you