(comala workflows) Is it possible to set a page property as a required field for a state transition?

Hi,

my question is about Comala Workflows. We have a page template including a table for some page properties. The user should fill in all values before the page can be approved. Is it possible to set the page properties as mandatory fields?

Thanks in advance,

Bettina

5 answers

1 accepted

This widget could not be displayed.

Hi Bettina,

As William suggested(thanks William!), we can provide the best support through our support portal as depending on the tags used we don't always see questions posted on Answers.

That said, something like this should do the trick:

{approval:Approval|@PAGE PROPERTY 1@=@empty@|@PAGE PROPERTY 2@=@empty@}

which will keep the approval disabled(no approving/rejecting/assigning) until all the page properties are set to a non-empty value.  We can also check if the pageproperty has user mentions or not with "usersdefined=@PAGE PROPERTY 1@, @PAGE PROPERTY 2@".

GIve that a try and let us know if that works for you. 

Thanks,
Miguel

This widget could not be displayed.

Hey Bettina,

Comala has their own support channel, I think there's more chance to get an answer from an official agent there:

https://comalatech.zendesk.com/hc/en-us

I hope this helps.

Cheers,
WZ

This widget could not be displayed.

Hi Miguel,

thank you for your help. I tried what you suggested, but unfortunately, it does not work properly.

My simple test workflow looks like this:

{workflow:name=SimpleWorkflow|label=simpleworkflow}
  {state:Draft|approved=Finished}
    {approval:RequiredFields|@Vorname@=@empty@|@Nachname@=@empty@}
  {state}
  {state:Finished}
  {state}
{workflow}

 I have a page template with two page properties ("Vorname" and "Nachname"). When I create a new page using the template, its status is "Draft". The approval is possible and changes the status to "Finished", even though the required fields are empty.

 

(Confluence 5.8.6, Comala Workflows 4.8.0.)

This widget could not be displayed.

I managed to get it working by setting @empty@ to a blank value

{set-metadata:empty}@Vorname@{set-metadata}

To enforce it is not empty, you need to negate it. 

{approval:RequiredFields|@Vorname@=!@empty@|@Nachname@=!@empty@}

Actually the better solution will be to use usersdefined condition

{approval:RequiredFields|usersdefined=@Vorname@,@Nachname@}
This widget could not be displayed.

Hi Team,

 

Can we mandatory a comment box in Comala Workflow so that approver when reject or Approve a page they won't be missed out mention the reason.

 

Thanks,

Rashmi

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

475 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you