Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,296,363
Community Members
 
Community Events
165
Community Groups

cannot edit draw.io diagram on confluence page

I'm not able to edit a draw.io diagram from the confluence page. We have 9 different draw.io diagrams on the confluence page and 8 of them are editable by hovering over the diagram and clicking the pencil icon

 

pencil.png

When I hover over the diagram that I'm trying to edit, the pencil icon is missing

 

Another way to edit is by clicking the draw.io diagrams link in the left sidebar on the page, clicking on the specific diagram, and then hovering over the diagram and clicking the pencil icon.

 

sidebar.png

 

When I do it this way, I am getting this error:

draw.io error.png

 

I am not sure what to do to fix this. The diagram shows properly on the page but we have no way to edit this diagram or export it to create a brand new diagram.

3 answers

1 accepted

ok thanks! the first solution you linked worked for me. For anyone else with this issue, just make sure you download the xml file and not the png

Like Zak Laughton likes this

The link to the first solution is broken. I ended having a bunch of draw.io diagrams that are not editable any more. I also lost some changes due to the fact that copying a diagram sometimes changes both links on a page. Not always. It worked for me in 80% of the cases. But when it made that error, then changing one of the diagrams will change both of them. Then you try to fix the other one ... until you finally end up finding out that you went forth and back on the same diagram. I am very frustrated with this solution.

When you insert and create new diagram in a page , and later you delete it from page, the diagram file is still attached to page

 

you can only insert the old diagram ( but not create new one ) by embed draw.io diagram , and can not edit it any more even you click to edit it 

 

This is the important bug between draw.io and confluence that need to be fixed ASAP

draw.io.JPGuser can only download the old diagram file and re-import to new created one manually ,  T-T

I'm searching for a way to change a draw.io  that for some reason is saved as embedded - and now not possible to edit. The link referenced here doesn't work anymore - any suggestions.?

open the old one , ctrl+a select all and ctrl+c copy

create new one (in another browser windows ) , ctrl+p

 

you can copy and paste + edit new one

Thanks for your fast reply :o)

The problem is that I created a entity diagram -

I can open it -  it's named 

Edit ‘Embed draw.io diagram’ Macro - 

with these menues

Current Diagram,Recent Diagrams,Search,Google, Drive,OneDrive,UploadFrom URL,CSV ,Import   can I get it back to entity diagram. 

I had this issue, and solved it by creating 2 draw.io diagrams (copy and pasted from my original draw.io diagram). Of the 2 draw.io diagrams aforementioned, the 1st one could not be edited, but then 2nd one could, so I just deleted the 1st diagram and continue working on the 2nd diagram. This is a bug in Confluence.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Confluence: Where work and wellness meet

Feeling overwhelmed by the demands of work and life? With a 25% increase in the prevalence of anxiety and depression worldwide during the pandemic, for most of us, it’s a resounding yes . 🙋‍♀️ ...

1,020 views 17 28
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you