It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

cannot create new content in confluence after adding reverse proxy Edited


I just added a reverse proxy in my JIRA-software+confluence setup and after some learning I managed to get it all working, I thought..

This morning I logged into confluence and clicked "Create" and i just got a spinning disk..

Looked in the log analyzer, and found this one: After upgrading Confluence, you are unable to create new pages or spaces Describes my problem pretty well.

It suggested 3 things to check:

proxyport, proxyname and scheme..

All are set as they should.. 443, confluence.domain,tld and https..

any suggestions of where to look for clues?


Confluence is running version 7.0.1

Apache2 vhost is configured like this:

<VirtualHost *:443>

ServerName confluence.domain.tld
ProxyRequests Off
ProxyPreserveHost On

RewriteEngine On
RewriteCond %{REQUEST_URI} !^/synchrony
RewriteRule ^/(.*) http://confluence.domain.tld:8090/$1 [P]

SSLEngine On
SSLCertificateFile /var/www/SSL/wildcard_domain_tld.crt
SSLCertificateKeyFile /var/www/SSL/wildcard_domain_tld.key
SSLCertificateChainFile /var/www/SSL/wildcard_domain_tld_ca.crt

<Proxy *>
Require all granted

ProxyPass /synchrony http://confluence-internal.domain.tld:8091/synchrony

<Location /synchrony>
Require all granted
RewriteEngine on
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
RewriteRule .* ws://confluence-internal.domain.tld:8091%{REQUEST_URI} [P]

ProxyPass / http://confluence-internal.domain.tld:8090
ProxyPassReverse / http://confluence-internal.domain.tld:8090

<Location />
Require all granted

The server.xml files proxy-part is like this:

<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
scheme="https" secure="true" proxyName="confluence.domain.tld" proxyPort="443"/>


All help is appreciated :)

1 answer

1 accepted

0 votes
Answer accepted

Hi Klaus,

Welcome to Atlassian Community. It's nice to have you join us.

Do you happen to see any errors in your atlassian-confluence.log file? See Working with Confluence logs for more details.

I would recommend reviewing your proxy setup against the following:

Let me know if you have any trouble or questions with that.





I actually managed to figure it out the other day :) just didn't have the time to post the reply yet.. So here it is. :)


After looking through the guides i noticed that during the different guides you proxy the socket-server connection but it wasn't mentioned to actually open the port in the firewall on the confluence server.. after some testing (Don't use firefox with disabled cache for testing), I got everything to work.

The problem was that i didn't get any use full errors in the logs other than to check the proxy settings "https", "port" and the domain..

So all I needed was, more or less:

# sudo firewall-cmd --zone=public --permanent --add-port=8091/tcp

on the confluence server :P


Thanks for the reply :)




Like Shannon_Spaniol likes this

Hi Klaus,

Thank you for sharing your fix! Glad to hear you were able to solve it.

Take care, and have a pleasant rest of your week.



Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

382 views 11 11
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you