Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

atlassian-python-api error when installing

I am running cloud9, just did a yum update to bring my code up to date, whenever I run the pip install command I get this error


Defaulting to user installation because normal site-packages is not writeable
Collecting atlassian-python-api
Using cached atlassian-python-api-3.8.0.tar.gz (118 kB)
Installing build dependencies ... done
Getting requirements to build wheel ... done
ERROR: Exception:
Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/resolvelib/", line 171, in _merge_into_criterion
crit = self.state.criteria[name]
KeyError: 'atlassian-python-api'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/pip/_internal/cli/", line 189, in _main
status =, args)
File "/usr/local/lib/python3.6/site-packages/pip/_internal/cli/", line 178, in wrapper
return func(self, options, args)
File "/usr/local/lib/python3.6/site-packages/pip/_internal/commands/", line 317, in run
reqs, check_supported_wheels=not options.target_dir
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 122, in resolve
requirements, max_rounds=try_to_avoid_resolution_too_deep,
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/resolvelib/", line 453, in resolve
state = resolution.resolve(requirements, max_rounds=max_rounds)
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/resolvelib/", line 318, in resolve
name, crit = self._merge_into_criterion(r, parent=None)
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/resolvelib/", line 173, in _merge_into_criterion
crit = Criterion.from_requirement(self._p, requirement, parent)
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/resolvelib/", line 82, in from_requirement
if not cands:
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/resolvelib/", line 124, in __bool__
return bool(self._sequence)
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 143, in __bool__
return any(self)
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 38, in _iter_built
candidate = func()
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 169, in _make_candidate_from_link
name=name, version=version,
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 306, in __init__
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 144, in __init__
self.dist = self._prepare()
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 226, in _prepare
dist = self._prepare_distribution()
File "/usr/local/lib/python3.6/site-packages/pip/_internal/resolution/resolvelib/", line 312, in _prepare_distribution
self._ireq, parallel_builds=True,
File "/usr/local/lib/python3.6/site-packages/pip/_internal/operations/", line 457, in prepare_linked_requirement
return self._prepare_linked_requirement(req, parallel_builds)
File "/usr/local/lib/python3.6/site-packages/pip/_internal/operations/", line 501, in _prepare_linked_requirement
req, self.req_tracker, self.finder, self.build_isolation,
File "/usr/local/lib/python3.6/site-packages/pip/_internal/operations/", line 66, in _get_prepared_distribution
abstract_dist.prepare_distribution_metadata(finder, build_isolation)
File "/usr/local/lib/python3.6/site-packages/pip/_internal/distributions/", line 39, in prepare_distribution_metadata
File "/usr/local/lib/python3.6/site-packages/pip/_internal/distributions/", line 97, in _setup_isolation
reqs = backend.get_requires_for_build_wheel()
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/pep517/", line 178, in get_requires_for_build_wheel
'config_settings': config_settings
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/pep517/", line 284, in _call_hook
raise BackendUnavailable(data.get('traceback', ''))
pip._vendor.pep517.wrappers.BackendUnavailable: Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/pip/_vendor/pep517/", line 86, in _build_backend
obj = import_module(mod_path)
File "/usr/lib64/python3.6/importlib/", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 994, in _gcd_import
File "<frozen importlib._bootstrap>", line 971, in _find_and_load
File "<frozen importlib._bootstrap>", line 941, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
File "<frozen importlib._bootstrap>", line 994, in _gcd_import
File "<frozen importlib._bootstrap>", line 971, in _find_and_load
File "<frozen importlib._bootstrap>", line 953, in _find_and_load_unlocked
ModuleNotFoundError: No module named 'setuptools'

1 answer

1 accepted

2 votes
Answer accepted

Closed - Used Sudo and it worked, previously sudo was erroring but I think that was because my cloud9 was out of date so did a sudo yum update and now trying sudo pip install it has worked

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,547 views 7 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you