Workbox appears empty in Confluence 5

We are using Confluence 5 and Jira 5.2. We have not upgraded from a previous version, the system is completely new and freshly installed. :)

In Confluence, the workbox appears blank or does not load, like described here:

https://jira.atlassian.com/browse/CONF-26648

and here:

https://confluence.atlassian.com/display/CONFKB/Workbox+Appears+Blank+When+Using+Internet+Explorer

I am using Firefox, but this issue appears in IE8, IE9 and Chrome as well.

Is there anything I can do to fix this or anything I've missed to configure?

2 answers

1 accepted

This widget could not be displayed.
Hello Henrike,

You could try to perform the workaround suggested in the bug report, that would be the following:

- Edit both templates\mywork.vm as well as templates\login.vm in the mywork-confluence-host-plugin-x.x.x.jar (which is stored in the confluence\WEB-INF\classes\com\atlassian\confluence\setup\bundled-plugins.zip).

Add this: <meta http-equiv="X-UA-Compatible" content="IE=EDGE,chrome=IE7"> in between the <head> </head> tags. It should look like this: mywork.vm <head> <title>${i18n.getText("com.atlassian.mywork.title")}</title> <!-- Need to add media query support for IE8--> <meta http-equiv="X-UA-Compatible" content="IE=EDGE,chrome=IE7"> <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no"> <meta name="context-path" content="${req.contextPath}"> login.vm: <head> <title>${i18n.getText("com.atlassian.mywork.login.title")}</title> <meta http-equiv="X-UA-Compatible" content="IE=EDGE,chrome=IE7"> <meta name="viewport" content="width=device-width, initial-scale=1.0"> Refer to Edit Confluence JAR files for more info on how to edit the JAR files. Best method is to use WinRAR, edit the files from within WinRAR, and update the archive after that. Another option also would be to upgrade to Confluence 5.0.2, that is the version for this problem. Hope this helps! Regards,
Rodrigo

we are expiriencing the same problem in Confluence 5.0.2 and 5.1. But only on IE8 and IE9 in our intranet infrastructure (self installed browsers outside work fine). I have opened a support case for this (CSP-98578). I suspect its some kind of security setting but I have failed to identify it so far.

Thanks Rodrigo, that turned out to solve our problem in all browsers! :)

This widget could not be displayed.

Hey Henrike,

Try to check whether all the following plugins are enabled in Confluence Admin >> Manage Add-Ons >> Show System Add-Ons:

  1. Notifications and Tasks - Common Plugin
  2. Notifications and Tasks - Host Plugin
  3. Notifications and Tasks - Confluence Provider Plugin

If any of them is not enabled, try to disable All the Notifications and Tasks plugin, then enable them one be one in the order above. If any of the plugins cannot be enabled, check in the logs to see why (normally it's a dependency issue). We've seen this happening in instances where the Share Page plugin is disabled.

Foogie

Hey Foogie,

thank you for this solution. Sadly, it did not work, but I am waiting for my server-admin to check the logs.

Regards, Henrike

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 17, 2018 in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

601 views 8 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you