Why is LDAP not working in Confluence 4.1?

I had LDAP working fine in 4.0 with an evaluation 2000-user license.

With the exact same settings, it's not working in 4.1 with a purchased 10-user license. The fatal error is:

[ldap.mapper.entity.LDAPUserAttributesMapper] getUsernameFromAttributes The following record does not have a username: {mailhost=..., mailroutingaddress=mailRoutingAddress: ...}

Does the 10-user limit apply on LDAP synchronization so it fails because we have more than ten users?

1 answer

Hi Robert!

It's not easy to set what wrong with your LDAP connection with Confluence without the logs, although I suggest you to try using an evaluation license to check if the user limit is causing this.

Hope it helps!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

308 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you