Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,882
Community Members
 
Community Events
176
Community Groups

Why do I get a blank bullet point as the first item of the TOC?

Deleted user Mar 10, 2017

This question is in reference to Atlassian Documentation: Table of Contents Macro

Every time I use this macro, it shows an empty/blank entry as the first item of the list.

I don't know why this appears!

5 answers

1 accepted

16 votes
Answer accepted

Make sure that there isn't an empty line above your first header, or make sure that everything (macros, tables, etc.) are set to the Paragraph style.

Deleted user Mar 12, 2017

The first line in the article, the one with the TOC macro on it, was set to Heading 2.

Changing it to Paragraph got rid of the blank bullet point item within the rendered TOC.

Like # people like this

To be more specific, my issues was that the Table of Contents as being formatted as a Heading 1, which was not immediately obvious. This caused the TOC to count as the first entry.

Like # people like this

This is what I needed! I ensured the fix by deleting my table of contents macro and then inserting it again.

Like Gaj Umapathy likes this

Actually, the correct answer is rather simple: 

Set the level to 1 instead of 0, this level 0 does not exist and is AFAIK a bug that has been reported but is still unresolved.

Thus, no bothering about spaces before or any strange stuff, just set the header level to 1. 


You can see that BTW in the preview, thus just play around with that, nothing will break :)

Like Thomas Müller likes this
Mimi T I'm New Here Dec 27, 2022

I tried everything and an empty entry still shows up. I found a workaround though, which is to enter ".+" for the option: "Include headings".

I had this same problem, even after making sure I wasn't typing anything extra and after already setting the TOC line of the document to be "Paragraph" style.  What finally worked for me was the following. Go to the "Edit 'Table of Contents' Macro" pop-up window (this pops up when you insert a new TOC, or when you double-click the icon for one you've already added), scroll down to the "Exclude Headings" field and enter the two characters w* here.  This essentially tells Confluence to leave out any bullet points that appear blank.

Yes! this helped me.

Make sure the TOC macro is set to paragraph level. By default it is set to H2 and this causes an empty bullet in the list.

Like David Stone likes this

I can confirm this! This is exactly what I needed. None of the changes to styles helped, and I verified had no extra lines or characters interfering. The only thing that helped the blank bullet in the ToC was to set my H1 to Paragraph... but I wanted the H1 in the ToC! Gah!

So I tried this one and lo-and-behold!!


Screen Shot 2022-08-30 at 9.49.39 AM.png

ToC BEFORE ADDING THE EXCLUSION FILTER


Screen Shot 2022-08-30 at 9.49.51 AM.png

ToC AFTER ADDING THE EXCLUSION FILTER

I can confirm that setting it to paragraph fixed my issue

Make sure the TOC macro is set to paragraph level. By default it is set to H2 and this causes an empty bullet in the list.

Screen Shot 2021-01-25 at 2.13.18 PM.png

This helped to understand the fix and actually fix it in no time. Thank you!

Great! That's the root cause.

Yes.. This worked for me.

Atlassian, why not make the TOC automatically set it's own heading to "Table of Contents" so you can avoid people setting it to paragraph level in the first place to fix a problem with a default behavior?

Why? Because the MVP/excuse-to-leave-applications half-***ed development mentality pervades even relatively pricey commercial products. As always, thanks Atlassian. Oh, unless there's a good reason a user would want a blank bullet to head their TOC? ¯\_(ツ)_/¯ 

Like EMCC Atlassian likes this

In the 'Exclude Heading' option, give  this regular expression ^$ (to exclude empty item in the list)

Sorry guys, its working only in preview, not after publishing!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events