Why am I getting the error that message that I have macros in the header?

Within about the last week all my pages have these error messages.

"The following macros are not currently supported in the header: style"

and similarly at the bottom 

"The following macros are not currently supported in the footer: style"

We didn't add any macros to either the header or footer so far as we know.

Tried this in both Chrome and Edge and get the same errors.

test.png

5 answers

Same, started sometime either yesterday or the day before.

We started getting it and I think I know why, but the error is confusing.

We have some override CSS that we put at the site level footer (this is because atlassian took away all the color settings in the new layout).  When I remove the {style} from the site footer the error goes away, but so too does the CSS override.

The confusing thing is the error says the macro isn't supported but it still seems to be functionally working.

Thank you.  That worked.  I deleted my style macros and the errors went away.

My macros were meant to hide features I didn't like.  In my case, Atlassian decided to get rid of the things I wanted to hide so it didn't matter.

For those wishing to make changes Administrator rights are required.  xxxxxx.atlassian.net/wiki/admin/custompagecontent.action

It is possible for those custom header and footers to exist at the space level as well. 

https://xxxx.atlassian.net/wiki/spaces/custompagecontent.action?key=YOURSPACEKEY

This works! My header had the below customization and Removing it resolved the macro style error.  

{style}
code {
padding: 1px 5px 1px 5px;
font-family: Consolas, Menlo, Monaco, Lucida Console, Liberation Mono, DejaVu Sans Mono, Bitstream Vera Sans Mono, Courier New, monospace, serif;
background-color: #eeeeee;
}
{style}

I fixed this error by doing the following:

1. Click on "Space Tools" (under Overview and Pages in the main space left hand menu)

2. Click "Look and Feel" sub-section

3. Click "Header and Footer" tab

4. In the Header box, delete:

{style}
.page-metadata, #breadcrumb-section {display: none;}
#system-content-items {padding:0px !important;}
{style}

5. Refresh browser

 

Note: I had multiple spaces, and had to repeat the above for each space.

This solution works!

Thank you.  That worked.  I deleted my style macros.

I am seeing it as well. I have no idea how to get rid of it.

I'm also seeing this.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,943 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you