Why I can't copy and paste a table in Confluence anymore?

I used to be able to copy and paste a table in Confluence with no problem, but now I cannot.  Pastes as a blank field, or a vertical list of mixed up letters from the paste.   This is a much needed feature in my work and need to get it resolved as soon as possible.  Can you help me?  I'm new to this forum.  Do I receive an email notification if someone has answered my question?  much thanks for your time, Keea

7 answers

1 accepted

4 votes
Answer accepted

You can ... and as long as I've been using Confluence, it's been a bit dodgy. 

Click and drag from the space above the table to the space below the table. Sometimes I even have copy some of the text in the preceding and following paragraphs to get it to work.

Thanks for this. It was counterintuitive. I had tried selecting all of the content of the table, and found that pasting merely pasted the text. But your approach copies the table as a whole. 

This was the first thing I tried. It doesn't retain the text formatting.

@Milo Grika

Oh my goodness, thank you for this comment! This kept bugging and frustrating me. In Chrome this works perfectly fine.

I'm not sure which browser you are using but I had the same problem. I switched to Mozilla Firefox and had no issues.

Keea

You don't say if you are copying from Confluence to Confluence or if you are copying from the outside like Word or Excel. If it is the former, I agree with Milo in that I've found grabbing an extra line or 2 above and below the Confluence table helps make the destination copy better. If it is the latter, I've found the copying from Excel is better than Word, so much so that I've taken to copying from Word to Excel and then to Confluence.

My question is how does one merge or split tables? That used to be so easy with the Wiki Markup editor.

Sandy,

Could you please help me how you could copy table from Excel to Confluence page ? 

Thanks

Prabha

Just select and copy all the cells you want from the Excel doc. Then in Confluence, create a 1 cell x 1 cell table and paste. It should build out the table for you.

Hello Keea,

If you are using Table Filter and Charts add-on, you can use a Copy Table button to copy any table to the clipboard in a single click.

This is so buggy, is there a bug report for this? It is unusable in both Firefox and Chrome. The selection with the mouse doesn't select anything and jumps around all over the place. Please fix it!

What Milo suggested worked for me in Chrome, i.e. selecting a few lines above qand below the table. Same trick did not work in Firefox though.

Agree that this should be made more robust, it's failry crucial piece of functionalty for me.

I have the same issue:
in the past I was able to copy and pasting rows and entire tables,
at the moment I cannot select an entire table with text over / under it as the selection simply does not select anything if I try to make it.
While if I select a table / some rows in a table and copy/paste it, it is pastes ad an only cell with all texts and images mixes as a long list.
This is crucial functionality for me and it is causing a loss of time - lost in recreating the same table and pasting texts and images row by row.... 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

298 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you