It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

When I go to create a Table of Contents on a "Blank page" it gives an error and no TOC shows

I am getting the following error when I try to insert a Table of Contents:

 

Error rendering macro 'toc' : [com.ctc.wstx.exc.WstxLazyException] com.ctc.wstx.exc.WstxParsingException: Duplicate attribute 'src'. at [row,col {unknown-source}]: [1,12919

 

Nothing is showing on the page. This is not a template. I chose "Blank page" to start. 

1 answer

Hello Antonia and welcome to the Community!

Thank you for coming to Community with your Confluence Cloud issue while creating a table of content macro.

From the error you provided and its output we’re able to see this matches a reported bug within the product. This bug impacts the TOC when it’s created with a content by label option.

Further information on this bug for Cloud products may be found at CONFCLOUD-67977. If this the issue you’re experiencing we would ask you to vote and watch this bug to receive future updates to its status.

There is no workaround for the Cloud products currently.

Further information on this bug for Server products may be found at CONFSERVER-53138. If this the issue you’re experiencing we would ask you to vote and watch this bug to receive future updates to its status.

The workaround is as follows;

Place TOC macro after Content by label macro. 

Regards,
Stephen Sifers

Hi Stephen,

 

How do I place TOC macro after Content by label macro? I don't see a Content by Label Macro on my page and when I tried creating one before the TOC I still got the following message on the PDF when I exported to PDF:

Error rendering macro 'toc' : [com.ctc.wstx.exc.WstxLazyException] com.ctc.wstx.exc.WstxParsingException: Duplicate attribute 'src'. at [row,col
{unknown-source}]: [17,9755]

Your help is really appreciated. Thank you very much

Like Stephen Sifers likes this

Hello Antonia,

I realized there was an error in my answer above. I've since correct this error by linking and proper bug reports for the cloud product and not for the server product.

For Cloud, there is no current workaround for this issue. I would ask you to provide your feedback on the linked bug above.

Regards,
Stephen SIfers

Like Antonia Manohar likes this
Like Stephen Sifers likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

159 views 3 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you