Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Webdav - able to create folders but not files


In order to migrating our documents from another system to Confluence we wanted to use the webdav plugin for bulk import. But we are not able to create any files using it. We can create folders, but not files.

jira repo.png


We followed the instructions detailled here :


We tried with Windows10 integrated webdav client both methods : 

  • Windows Network Drive
  • Windows Web Folders

In both case we are able to reach the webdav and access to the spaces and subfolders, but not to create any files (using wether drag and drop or right-click/create). Windows is responding an error "0x8000ffff Unexpected Error"


erreur windows.png


We tried using a different webdav client (WinSCP) and encountered the same behaviour : we are able to access to the spaces, to create folders, but not to create any files. WinSCP is responding a 500 error.


erreur winscp.png

Files we tried to create are txt, jpg, pdf, png,...

We connect on the webdav using an account which is members of confluence-administrators group.

We tried with disabling strict path checking and encountered the same behavior.

Logs are returning the following error message :


2023-09-27 17:32:22,364 ERROR [https-jsse-nio-8443-exec-8] [extra.webdav.resource.PageResourceImpl] addMember Unable to add/update attachment default/Global/REP/REPRISE HOME/Reprise Teamforge/Nouveau document texte.txt on page page: Reprise Teamforge v.3 (21069829)
-- url: /plugins/servlet/confluence/default/Global/REP/REPRISE%20HOME/Reprise%20Teamforge/Nouveau%20document%20texte.txt | traceId: c394bbd1792ee2b7 | userName: balanea Permission denied


2023-09-27 17:32:22,367 ERROR [https-jsse-nio-8443-exec-8] [extra.webdav.servlet.ConfluenceWebdavServlet] service Unexpected error
-- url: /plugins/servlet/confluence/default/Global/REP/REPRISE%20HOME/Reprise%20Teamforge/Nouveau%20document%20texte.txt | traceId: c394bbd1792ee2b7 | userName: balanea


Does anyone has an idea of this behavior's cause ?


Thanks in advance for your help.

2 answers

1 accepted

0 votes
Answer accepted


Finally we noticed that the temp directory used by java to writte the files doesn't have the good authorizaitons defined.

We changed it and it worked.

0 votes
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Sep 28, 2023

Hi @Antoine B 

I think that unfortunately you might be hitting this bug

Could you confirm that by trying to use WebDav on a different machine than Windows (or not Windows 10)?  

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events