Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Using Table filter can i define default sort for tables in confluence

Created Tables in a confluence page

wrapped the table with table filter macro

Specified default sorting in the table view tab

Click on Save

Q1. unable to see the table getting sorted as specified.

Q2. if I enter more rows with values in the tables, will sort be retained.?

 

1 answer

Hi @Sandhya Srinivasan

For Q1: It is not an expected behavior for the macro. As I understand, you sort a manually created table, not the macro generated one (if I am wrong, please, specify the macro then). After hitting the Save button, the sorting should be saved. Try to experiment with other columns/tables.

If the bug is still here, please, raise a support ticket and attach the page storage format - we'll recreate the page with your table and try to fix the issue (go to the right upper corner of the page -> ... -> View Storage Format).

For Q2: Newly added rows will be sorted immediately as is specified in the macro body.

The macro settings:

Sort 1.pngAdding a new row:Sort 2.png

The published page:

Sort 3.png

Thanks for your help.

Yes, I manually created the table.

Also, I had the header with some merged column cells. I think there is a problem with the instance we have in our organization.

i see my tables like this now: Table header upside down. Sort did not happen.

image.png

The problem is in the merged headers - there are several difficulties with them in Confluence. Try the following workaround: wrap your table in the Table Transformer macro (don't make any changes in the settings) and then in the Table Filter macro with the default sorting.

Sort 5.pngSort 6.pngThe Table Transformer macro will adjust your complex merged headings into the simple ones and the default sorting will be applied as usual.

I did exactly what you have said..

i am not able to understand where the problem is.. see my tables below

image.png

And this is how it shows after saving. Long table headings..

image.png

Hi @Sandhya Srinivasan ,

You've done everything right - the problem is that tables with merged cells are unsortable in Confluence. Here is their ticket where you can vote for the issue.

The Table Transformer macro helps to separate merged headings (see my previous screenshots and your own table - it is the reason that your headings are long, they are not merged and become sortable).

You can also exclude the Table Transformer macro and rearrange your headings manually so that there will be no merged cells.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

26 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you