It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Using Confluence Coud, attempting to insert a Jira Report / Pie Chart doesn't work.

I'm having some issues trying to add a Jira 2d Report of type Pie Chart to a Confluence page.

Step #1: I have a confluence page where I want to add the report:

DeepinScreenshot_select-area_20190924141859.png

Step #2: I select the Jira widget:

DeepinScreenshot_select-area_20190924141952.png

Step #3: I configure the pie chart:

DeepinScreenshot_select-area_20190924142114.png

I believe that when I select the display option for Status, I get an error in the Javascript console.  Here's the error:

DeepinScreenshot_select-area_20190924142348.png

I'm not sure if that's related.  Once I click Insert to insert the new report on the my Confluence page, nothing happens.  The page is not updated with any new content.  Any suggestions?

1 answer

0 votes

Hi Bret,

Thank you for contacting us about this. 

  1. Can you tell me, if you still have any pages on the old editing experience, are you able to add the macro there?
  2. If you were to use the / shortcut menu in Confluence to add the macro, does that work instead?
  3. Does this occur on several different browsers?

I suspect it could be related to CONFCLOUD-65519 (When editing a Jira Gadget macro, the internal Save button is not shown), but I would need further information on that.

Let me know how the tests work, and we can proceed from there.

Regards,

Shannon

Thank you, Shannon. Is there a way to control the format of the text in the diagram?

Hi Christine,

It's not possible, unfortunately, since with Confluence Cloud modifying the theme including fonts is a restricted functionality.

See Functional Differences in Confluence Cloud for more information. Let me know if you have any questions about that.

Regards,

Shannon

@Shannon_Spaniol we're having the exact same issue with Confluence and Jira Cloud. The insert button in the 'insert jira chart' window is visible and clickable but even that the preview shows the the chart / pie it doesn't show on the page. We tested from different browsers and different computers and no one was able to add a Jira macro to Confluence.

Hi @Ben_Sharir,

Welcome to Atlassian Community! It's nice to meet you.

Are you encountering the  same error that @Bret_Truchan was encountering in your Developer Tools console?

Error: undefined missing confluence/api/navigator-context

If so, I think this issue might be related to the following bug:

  • CONFCLOUD-65999 Cannot Add "Pie Chart" Macro to a page using the new editor

However, the workaround stated there is to use the Jira chart macro, which you're both already using. There's a comment internally about how it may be related to another issue with gadgets, but it appears that issue might be already resolved. 

I'm going to try and see what I can find out about this and I'll let you know if I hear anything. 

Regards,

Shannon

@Shannon_Spaniol yes, we're encountering the same error that @Bret_Truchan is encountering in the developer console (see screenshot). You're right about the workaround stated in CONFCLOUD-65999 is to use the Jira Macros that we're both already using. I'm not sure about the internal comment with this issue being related to gadgets as even if it's resolved, we're still unable to use macros in Confluence as of now. Your help is appreciated.

Annotation 2020-01-24 105810.png

Hello Ben,

Thank you so much for providing those details. I'm trying to get in touch now with the development team lead to see what we should be doing; if the bug I sent is in fact the same cause as this one, or if this is a new issue entirely.

I'll report back when I have any details.

Regards,

Shannon

Like Ben_Sharir likes this

Good morning!

I spoke with the team, and it appears that the bug is a duplicate of this case:

  • CONFCLOUD-67476 Inserting a Jira Chart from Jira macro issue does not work

This one is on its way to being fixed, and is being tested in staging at this time. I'll let you know once the release is confirmed, and then we can see if this fixes the issue you all are having.

There's a workaround we can test now:

Instead of selecting the Jira Charts macro from the Jira issues macro menu, directly select the Jira Charts macro from the macro browser by selecting the View More option on the insert/+ dropdown.

Could you all give that a try and see if it works for your site?

Regards,

Shannon

Like Ben_Sharir likes this

Thanks @Shannon_Spaniol , this workaround works!

That's great, Ben! Thanks for confirming that.

I'll be watching the CONFCLOUD-67476 bug in the meantime, and I'll follow-up with you when it's resolved.

Regards,

Shannon

Like Ben_Sharir likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

32 views 2 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you