Users Are Getting Access Denied message After Admin Grants Access to Confluence

My license allows 40 users on Confluence. As an admin I've granted Confluence access to my users, however everyone I've granted permission to is getting an Access Denied page.

I followed the instructions on this Help page and nothing has worked: https://confluence.atlassian.com/display/ONDEMANDKB/User+Can't+Access+Confluence

I've tried the following to no avail:

  • Granted access to individual users for Confluence and specific spaces

  • Created a group called "Confluence Users" and granted the group Space Permission to a space

  • Granted "Confluence Users" Group Global Permission Access
    *I tried adding individual users to Global Permission but none of our team member names were showing up. I was able to add admins, but non-admins weren't showing up in the auto-search.

I see that another Confluence user had this same issue, here: https://answers.atlassian.com/questions/276091/you-have-not-been-granted-access-to-confluence

Is my issue related to an existing problem? Please help.

Thanks,

Tanisha

8 answers

1 accepted

Hiya mate,

You could be hitting into this user management bug. Feel free to raise an issue under the OnDemand project in https://support.atlassian.com. We will apply the fix for you.

Interesting, could you please go to Confluence admin > Global permissions and take a screenshot of that page?

Also in Confluence Admin > Users, check for a user that is also failing to login and click in edit groups, take anotehr screenshots.

After you send the above I will be able to confirm you if theres anything we can try or if you will need to raise a support case at support.atlassian.comso our OnDemand team can validate this.

Thanks and Regards,
David|Atlassian Support

Third screenshot attached.

Hi Deividi,

I'm attaching the screenshots you requested. I'm providing three images because I wasn't sure if you wanted me to show you the edit user view of one of the failing users or a group list view.

  • Confluence admin > Global permissions
    File: "View_Global_Permissions_-_Confluence_-_2014-05-20_09.25.41"
  • Confluence Admin > Users > User (Who's failing to Login)
    File: "User_Management_-_User_Cant-login-_2014-05-20_09.28.45"
  • Confluence Admin > Users > Groups > Confluence Users (a group I created)
    File: "User_Management_-_Groups_confluence-users-group-_2014-05-20_09.30.04"




Third screenshot attached.

Everything looks correct, could you please proceed opening a case to support.atlassian.comso OD team can check this?

Make sure to add those screenshots and the other this awnser post.

Thanks and Regards,

David|Atlassian Support

Attached 3rd screenshot.

The problem was resolved. A fix was implemented for my issue. Thanks.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,932 views 27 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you