User macro mangling content inside

I'm trying to create the world's most simple user macro in Confluence V5:

The macro type is: Rendered

## @noparams
$body

Looks good so far in use...any content I type inside the macro box in the editor displays its text. I can even embed a {pane} macro inside and it renders great!

As soon as I try a {tip} macro, it breaks. It seems to mangle the HTML inside...the span for the tip icon isn't closed and leaks into the rest of the content:

<span class="aui-icon icon-success">
      <div class="message-content">
.
.
.
      </div>
</span>

Any suggestions on how to get this rendering properly? Thanks.

2 answers

1 accepted

Hi David,

For accessing confluence macro's in xhtml, you should use format like this:

<ac:macro ac:name="profile">
 
    <ac:parameter ac:name="user">admin</ac:parameter>
 
</ac:macro>

Hope this helps!

But I can't expect end-users to know this...I can't predict what macros users will put inside my user-macro.

Maybe the question I should really be asking is: are other macros supported inside a user macro?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

982 views 14 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you