I am upgrading Confluence version 6.15.2 which is hosted on CentOS and has a backend database running MySQL 5.6. We attempted upgrading from Confluence 6.15.2 to 7.10.0. We ran into an issue updating the index.
Here are the related log entries:
Upgrade failed. Please consult the system logs for details. You will need to fix these problems, restore your database and confluence home directory to the pre upgrade state. Then retry the upgrade. Upgrade error message: Upgrade task com.atlassian.confluence.upgrade.upgradetask.SplitIndexUpgradeTask@1ad30825 failed during the UPGRADE phase due to: Failed to read id for journal 'main_index': null; nested exception is java.lang.NumberFormatException: null
2020-12-23 02:51:28,751 ERROR [Catalina-utility-1] [atlassian.confluence.plugin.PluginFrameworkContextListener] launchUpgrades Upgrade failed, application will not start: Upgrade task com.atlassian.confluence.upgrade.upgradetask.SplitIndexUpgradeTask@7e273617 failed during the UPGRADE phase due to: Failed to read id for journal 'main_index': null; nested exception is java.lang.NumberFormatException: null