Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Upgrading MySQL database from 5.6 to 5.7 to 8.0, receive error 3780 when dumping data

Upgrading MySQL database from 5.6 to 5.7 to 8.0 for the most recent Confluence version (7.19). 

The setup of the database, confluence installation and the database connection are all successful. However, when I go to dump the new data into the database I receive this error (the following two commands are what I used to dump the data into an sql file and to dump the data into the database).

1.  mysqldump -u confluence -p --databases confluence > “D:\mysql-backups\mysql5.7-nofurthercollation.sql”

2. mysqldump -u confluence -p confluence < D:\mysql-backups\mysql5.7-nofurthercollation.sql


Online Confluence documentation suggests that when making changes to a large number of columns, it may be necessary to ignore foreign key constraints while you update the database. This is done by executing this query in mysql ‘SET FOREIGN_KEY_CHECKS=0;’ and ‘SET FOREIGN_KEY_CHECKS=1;’ once you’re done. I tried this approach but still received the same error message.

To find the column referenced in the above error, I execute the following command (This MySQL statement identifies columns with the incorrect character sets or collation):


212 rows are returned from this query, including the columns from the error.


The character set and collation are utf8mb3 and utf8mb3_bin, respectively. The first column is the table name.

Thank you for your help.

2 answers

Did you run mysql_upgrade after the upgrade of mysql8 ?

0 votes
Fabio Racobaldo _Herzum_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Sep 14, 2022

Hi @Jonathan Cooper ,

the secondo command is wrong. In order to restore DB from dump you should use "mysql" and not "mysqldump" command.

mysql -u confluence -p confluence < D:\mysql-backups\mysql5.7-nofurthercollation.sql

Please could you check?


Apologies, that was a typo on my part. I did use the correct command you said.

Like Java Pirate likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events